How to install OpenWrt 21.02 on Teltonika RUT955 router?

Has anyone successfully flashed Teltonika RUT955 router running Teltonika RUT9XX_R_00.06.07(should be modified OpenWRT Chaos Calmer) with vanilla OpenWRT 21.02.1? If I try to upgrade the firmware with "sysupgrade" utility, then I get the "Invalid image, not supported on this device." error message:

root@Teltonika-RUT955:~# uname -a
Linux 3.18.44 #1 Wed Sep 30 10:11:52 UTC 2020 mips GNU/Linux
root@Teltonika-RUT955:~# sysupgrade -v /tmp/openwrt-21.02.1-ath79-generic-teltonika_rut955-squa
Invalid image, not supported on this device.
Image check 'platform_check_image' failed.

Have you tried the sysupgrade-file ( ) instead of the factory-file?

1 Like

Yes, but I got the same error message. In addition, I tried from the Teltonika web GUI, but unfortunately without success.

Next try, have you tried the builtin device recovery ( ) and used the openwrt-factory-file?


Using 21.2.0 on multiple RUT955's. Very first flash the openwrt-factory image, using U-Boot web recovery. After this initial flash, you can use sysupgrade.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.