How to install LEDE onto Fritz 3370?

I have my third Lantiq device right next to me. A Fritz 3370.

Unfortunately I'm unable to flash LEDE onto the device.

From the LEDE download page I can get these two files:
lede-17.01.0-r3205-59508e3-lantiq-xrx200-FRITZ3370-squashfs-sysupgrade.bin
lede-17.01.0-r3205-59508e3-lantiq-xrx200-FRITZ3370-ubifs-sysupgrade.bin

I don't know what ubifs is, therefore I went with the familiar squashfs image and flashed it via ADAM2 to the mtd1 device.
But mtd1 is too small for the whole image.

Next step. Compile LEDE myself. This results in a squashfs-sysupgrade and an ubifs-sysupgrade image. Additionally two u-boot images. One with the suffix 'eva' and one with the suffix 'ram'

I then tried to flash the u-boot_eva into mtd1 and the squashfs into mtd0. On the serial console I now get this error:
<ERROR: FIRMWARE_ILLEGAL_CONFIG >

So what am I doing wrong? Do I have to replace ADAM2 with u-boot? If yes, how? And how can I go back to stock firmware?

Thanks

:sob:

After a a bit more testing. I accidentally overwrote the wrong partition and it doesn't start at all anymore. Can anyone provide me with information about debricking a lantiq device?

Did you try AVM recovery?

https://download.avm.de/fritz.box/fritzbox.wlan_3370/x_misc/english/

Stormy667

Yes. But I was stupid enough to completely destroy the ADAM2 bootloader. AVM's recovery tool relies on a working bootloader.

Since it's dead now anyways I'm going to try to fix it with JTAG. I hope that one of the two u-boot binaries is able to boot this device.

Have you fixed it with JTAG? Could you add the information to the wiki?
https://wiki.openwrt.org/toh/avm/fritz.box.wlan.3370

So why are these files (squashfs and ubifs) here:
https://downloads.openwrt.org/releases/17.01.4/targets/lantiq/xrx200/
3370
if there is no way to put them at the modem/router? How did the developer used them?

To anyone who knows how to flash partitions: Is the main problem with 3370, the 256KB Serial storage and 512MB NAND storage? What are these kinds of storage. Other modem/routers have just Serial, or have something else?

1 Like

I have myself a spare 3370. Wasnt able to get any useful information how to flash it...

Complete support for the 3370 was integrated yesterday. The commit message includes flashing instructions. You'll need to use a recent development snapshot.

Disclaimer: I haven't tried this myself since I don't have this box.

1 Like

Unfortunately I was not able to fix it. Given that there are similar devices out there, which are a lot easier to flash I went with a TP-Link 9980

I will give it this a shot.

Work like a charm! Just use a linux for it. Windows was, like always, a pain in the ass using ftp. Next step will be to set up the box entirely and try the box on my vdsl2 connection with sqm, since i have high hopes that the cpu is strong enough for my vdsl2 connection.

just giving a feedback: After extracting, with the help of a friend, a vectoring capable firmware from avm, i was able to use the router for my internet connection. Sadly, irqs are eating all the cpu. SQM is impossible to use, and not even the full 100/40mbit i have. The 3370 manage with offloading around 93~mbit. Good luck if you want to use some upload at the same time.

So, i guess the router fitt best with a 50mbit connection.

For those interested, im probably going to test this weekend different dsl drivers in matter of performance, and i will test bridge mode aswell. I dont want to give up as easily on this device.

Once im ready to make a new thread, i will tag all threads related to the 3370.