How to install LEDE on Fritz!Box 3370?

Have you tried to build and flash this fork?

No, I didn't know about this repository, thanks for the pointer!
Especially the ECC-related commits in fb3370-4.9-eccondie-WIP look interesting.

Looks like the ECC-on-die patch got mainlined for Linux 4.14, this makes things easier:
start with a current git master and apply the most recent versions of mkresins FB3370 patches (do NOT use the ones I linked above, these patches are a moving target), build with kernel 4.14 and use "on-die" ECC mode:

diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 4ae3a9a..2180b83 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -12,7 +12,7 @@ FEATURES:=squashfs
 SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 MAINTAINER:=John Crispin <>
 define Target/Description
        Build firmware images for Lantiq SoC
diff --git a/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ3370.dts b/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ3370.dts
index 40d77b4..2943f72 100644
--- a/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ3370.dts
+++ b/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ3370.dts
@@ -205,6 +205,7 @@
                reg = <1 0x0 0x2000000>;
                #address-cells = <1>;
                #size-cells = <1>;
+               nand-ecc-mode = "on-die";
                partitions {
                        compatible = "fixed-partitions";

This results in bootable images for me.

Just to be sure you mean this git with the patch you appended to your message, right?

Have you found the time to figure out what works and what doesn't?
Did you try to use one of the sysupgrade images from the build bot?

Yes. Just the most recent versions of those patches.

No, not yet. I tried to do a sysupgrade with my own build, which didn't work.

I found the time to compile it and set it up Wifi and the switch including VLAN seem to work fine so far. I didn't test the DSL interface since I don't use DSL anymore.

Edit: Looks like a lot of network io performance was lost, caps at ~55 mbit/s.

Edit2: Today a few commits got pushed from a staging repo to the main repo which add support for the FB3370! link

You can enable kernel 4.14 on lantiq and test flowoffload, in my tests I go from ~80-85 MBit/s to 96 MBit/s on a BT Business Hub 5 type A (SMP enabled).

1 Like

I just flashed my spare 3370 and it booted right up!


Hi Julien,

would you be willing to share some details how you proceeded?
Have you build the image yourself, or you uses latest 18.x. release from openwrt and loaded over WebGUI of FritzBox?

Sorry for stupid questions, just having a spare 3370, HW rev.5 with the UrLoader 2186 with 30 seconds limitation on adam2, so any hints, or help would be very appreciated! Tried it with 15.x, with 17, and 18.x. image, no luck. Would be amazing to have openwrt on that box.

I guess you already know the 3370 devicepage

It mentions:

Since commit 0b62fe5e OpenWrt can be installed using the eva/adam2 bootloader. Within the same HW revision 5 of the Fritz!Box 3370 different NAND flash chips are used and the correct image has to be chosen. Please read the detailed commit message before trying an install.

Only snapshot has the specific images for the different flash chips used, see

Hmmm... just noticed that the sanpshot images refer to rev2, not rev5... confusing :-/

Actually, yes I do. However, i somehow missed the point about the snapshot, being separate folder tree... and with the broken links to wehaveaforum pictures etc., was really not sure how to move.

Will have to open the box tomorrow, to see the type.

Thank you!

Yeah, it's a shame that is down... really informative site with lots of usefull information.

I have a hynix model. Yes, you are correct the notes and iimage seems to be for rev.2 . Anyhow, not sure what is wrong, but the box behaves strange.. Would be great if i.e. BIGFAT can share what revision he has?

ftp> open
Connected to
220 ADAM2 FTP Server ready
User ( adam2
331 Password required for adam2
230 User adam2 successfully logged in
ftp> debug
Debugging On .
ftp> bin
---> TYPE I
200 Type set to BINARY
ftp> passive
Invalid command.
ftp> quote SETENV linux_fs_start 0
---> SETENV linux_fs_start 0
200 SETENV command successful
ftp> quote MEDIA FLSH
200 Media set to MEDIA_FLASH
ftp> put C:\frtizbox\openwrt-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-eva
-kernel.bin mtd1
---> PORT 192,168,178,20,5,255
502 Command not implemented
---> STOR mtd1
425 can't open data connection

any ideas?

solved problem with passive command, box accepts quote PASV and switches into passive mode...

Anyhow, then two new problems while puting the file...
502 command not implemented
551 unknown Mediatype

You can still try to find the links in the internet archive.

I will until the next weekend. Currently Im really busy since i started a new job. And i already forgot the revision :stuck_out_tongue:

Back then i used the snapshots because the files for the normal release (18.06 and the rc) are not available.

Sadly, i will fallback on Fritzos and keep it as reserve, since vectoring on the 3370 with openwrt and proprietary vectoring drivers was not stable. I got for free a vigor 2760 that im now using as a modem.

By the way: use a linux for the flashing process with adam. Windows was for me a pain in the ass...


No problem Julien, doesn´t hurry. I tried as well Linux , coming to same result. ONce trying to upload the kernel to mtd1 , I get a reply 502 command not implemented and that´s it. Using the files from snapshot repo as tmomas made me aware about.

So not sure if it´s by the revision, or if the problem is sitting on the chair... A pitty there are no more people interested on that boxes, as I think they are fine, so would be more input :slightly_smiling_face:

Btw. when you say FrtizOS image, are you using Freetz ?

Sadly no since avm is too lazy to release the latest kernel sources for this device.

Neither Windows it's own ftp executable nor quote PASV can achieve a passive ftp connection.

Any *nix system should be fine though.

As my both units I got from the 3370 are HW rev.5 with the UrLoader 2186 with 30 seconds limitation on adam2, I take it as being screwed... Unfortunately I´m no crack to get it stripped off and resolved :frowning:

Let´s hope some time in future , there will be somebody getting it work.

@fritz3370 As you have done some testing, would you like to update the wiki? :slight_smile:

1 Like