How to install Lede on Asus RT-AC56U?


i am looking to install Lede onto my Asus RT-AC56U router.

how best can i do this?

i checked out this link ( and it mentioned i should be able to navigate here ( and to download the ".bin" file, however both links direct me to a ".trx" file.

i have the latest AsusWRT firmware currently installed.

suggestions, thoughts?

minor note - the picture at the bottom of the TechData is a D-Link, not Asus :slight_smile:



The .trx file is the firmware format for ASUS.

Follow the ASUS instructions for upgrading firmware on page 83 of the User Manual...

4.7.3 Firmware Upgrade
NOTE: Download the latest firmware from the ASUS website at (substitute LEDE firmware download)

To upgrade the firmware:

  1. From the navigation panel, go to Advanced Settings >
    Administration > Firmware Upgrade tab.
  2. In the New Firmware File field, click Browse to locate the
    downloaded file.
  3. Click Upload.
    • When the upgrade process is complete, wait for some time for the
    system to reboot.
    • If the upgrade process fails, the wireless router automatically enters
    rescue mode and the power LED indicator on the front panel starts
    flashing slowly. To recover or restore the system, refer to section 5.2
    Firmware Restoration.

It's neither Asus nor D-Link: It's a generic picture, since nobody uploaded a correct picture yet.

thanks guys, however it wont let me install the image :frowning:

any suggestions?

i am currently running the latest version of AsusWRT: FW_RT_AC56U_30043807743

i get the following message:

Invalid Firmware Upload
To comply with regulatory amendments, we have modified our certification rule to ensure better firmware quality. This version is not compatible with all previously released ASUS firmware and uncertified third party firmware. Please check our official websites for the certified firmware.



Try using TFTP.

TFTP tutorials…


i was able to successfully load LEDE :slight_smile:

not sure why i wasn't able to flash to LEDE from latest AsusWRT, however i was able to successfully flash to ddwrt build 33555 via webgui without any issues. after which i was able to successfully flash to LEDE via webgui as well.


another question, since i don't use IPv6, would it be safe to remove the following packages (are there more, less, etc.?) related to IPv6, or are they related to other packages and/or cause any sort of issues?

  • ip6tables
  • kmod-ip6tables
  • kmod-nf-conntrack6
  • kmod-nf-ipt6
  • libip6tc
  • luci-proto-ipv6
  • odhcp6c

similarly, i don't use the router as my DNS server or DHCP server, so could i also remove these, or are they needed for other packages/services running, or "client" dns (router itself trying to do a dns lookup?), etc.?

  • dnsmasq
  • odhcpd

lastly, i also don't plan on using PPPOE at all either:

  • kmod-ppp
  • kmod-pppoe
  • kmod-pppox
  • luci-proto-ppp
  • ppp
  • ppp-mod-pppoe

opps, and wifi, would that be only this one?

  • wpad-mini



1 Like


Still cautious, and have only slowly been turning things off.

As for the various packages themselves, i'm still not sure exactly which one(s) i can remove without issue and possible adverse affects, as this is my main router.



it's been a while, my apologies.

so i disabled the pppoe stuff on both this router and another (used as AP), but found when "testing" on my AP, that certain packages are linked together. for example if i recall correctly, removing "ip6tables" also removes the non ipv6 tables as well. which for the AP is fine, but not for this upstream router.

i did however disable ipv6 more "globally" via "sysctl", but noticed that during a reboot/startup of the device, that certain packages run/start after the sysctl modifications are applied, and therefore it is still running.

as such i tried to utilize the luci gui startup script section (since it runs after startup essentially) to re-apply my sysctl config (sysctl -p ; as the file itself keeps the changes), but i'm not sure on the syntax here as it doesn't seem to be working:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

sysctl -p

exit 0

any suggestions on being able to re-apply my "sysctl" settings?

any suggestions on how to create a custom startup script with the command?