How to install a driver in raspberry pi


I am trying to install a driver in my raspberry pi with lede. The driver is at



That dongle uses the MT7610U chipset, which has no support in the Linux kernel at the moment. It seems to be possible to install the driver from MediaTek on Linux.

EDIT: Damn, that driver is for kernel 3.11. It might be easier to find a different adapter.

EDIT 2: Actually, it should just work with kernel >=4.2. What does the Pi return when you run "uname -a" and "lsusb" with the adapter plugged in? My bad, that's for the MT7601U and you have the MT7610U.

I see what u mean. I'll order another adapter ....

Well then, i have another adapter. It is an (info lsusb):

0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter

When i look in ifconfig there is no wlan1. So i guess the driver is not present.

What should i do? And could i have known where to look?

Thank you for any help!

EDIT: i found (chinese site) a kmod-rtl8192cu and tried to install. I get an error"Cannot satisfy the following dependencies for kmod-rtl8192cu: kernel (= 4.4.47-1 .......).

1 Like

If your RPI has LEDE installed, you shouldopkg update opkg install kmod-rtl8192cu

OP, usually you won't need to download drivers/programs off the internet when using LEDE/Linux. They're usually available through a package manager, which will also keep them up to date.

EDIT: My policy is usually: plug in > doesn't work > use something else. It keeps my life simpler, and it's worked well for me so far.

1 Like

I have lede installed. Should wlan1 automatically show up when i do ifconfig?

Thats not the case...

Maybe on 'ifconfig -a'

If not, unplug the stick, plug it in again and look with 'dmesg' if it's reconized.

Will try the -a tomorrow. When reading the 'dmesg | less' i see it in the list.

Ifconfig -a gives the same as without the -a.
Dmesg lists the adapter as : usb 1-1.5

I found this post stating it could be related to the pi3 and the order in which it loads the wifi device drivers. At the very end of this post it seems the only solution at that time (2016).
Post can be found here.

In a normal raspberry installation i would try this. But i havent a clue what mess i would create when i'ld try this in my lede setup.

i hope someone can help me out here;))

Many thanks!