How to get working Internet via IPoE

Installed successfully on the RT-AX1800U OpenWRT (I'm new) with LAN cable, but one problem - the Internet does not work (well that is understandable, it must be configured).
ISP provides internet via IPoE (connected in WAN port), but how to do it on OpenWRT is not clear. I tried all the options, set in the device "wan" mac address from ISP, worked only IPv6 (WAN6) but IPv4 (WAN interface) did not work, despite many restarts of the router and interface.

Upgrade to the latest stable release and reset the settings to factory defaults.
Then edit the network config and specify the MAC from your ISP contract as follows:
[Solved] How to clone MAC Address for 21.02.0? - #4 by vgaetera
Save and reboot to apply the changes, and it should basically work.
If the issue persists, check this:

ifstatus wan; ifstatus wan6

Still the same (even after reboot), IPv4 not working

ifstatus wan
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcp",
        "device": "wan",
        "data": {

        }
}

IPv6 still working:

ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 184,
        "l3_device": "wan",
        "proto": "dhcpv6",
        "device": "wan",
        "updated": [
                "addresses",
                "routes",
                "prefixes",
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "[REMOVED]",
                        "mask": 128,
                        "preferred": 10613,
                        "valid": 10613
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "[REMOVED]",
                        "mask": 64,
                        "preferred": 10613,
                        "valid": 10613,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "[REMOVED]",
                                        "mask": 64
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "[REMOVED]",
                        "metric": 512,
                        "valid": 1616,
                        "source": "[REMOVED]"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "[REMOVED]",
                        "metric": 512,
                        "valid": 1616,
                        "source": "[REMOVED]"
                }
        ],
        "dns-server": [
                "[REMOVED]",
                "[REMOVED]"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "[REMOVED]"
        }
}

Config:

config device
       option name 'wan'
       option macaddr '**:**:**:**:**:**'`

Make sure you allow DHCP client replies in the firewall config:

If the problem persists, try capturing the relevant DHCP traffic:
https://openwrt.org/docs/guide-user/network/protocol.dhcp#troubleshooting

upd. So, after restarting router and WAN interface 1-6 times and reconfiguring the WAN device (unconfiguring and re-writing the MAC address from the ISP), it finally gets IPv4.
It turns out that what @vgaetera firstly suggested - works. (but after 1-2 hours)

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.