How to get wired internet on Raspberry pi?

Openwrt boots into some weird br-lan where it doesnt actually have internet (cant ping google). Ive read around and cant figure out how to get eth0 to give me internet. Since the pi is a model 1 b it doesnt have built in wifi, so i need to update and install support for my tp-link usb adapter before i can ssh into it and get a gui. at least thats what im thinking, but im pretty overwhelmed by openwrt. it seems like the tutorials are written by people who already now how to use it for people who already know how to use it. but anyway, im determined to get this thing working.

Can someone please help me understand how to get internet over the ethernet eth0 interface? The official page i found essentially just tells you to put "option proto 'dhcp'" in /etc/config/network for the wan interface, but i tried that and it didnt work. also i had no idea what to do with the stuff that was already in the network config file.

What is uci by the way? Is it better than manually editing the network file?

1 Like

it is the same as any other headless web managed device. you plug it into your network... and assign your client the correct ip settings to access it

you can't blame openwrt for a lack of network skills. you can take any off the shelf router, don't plugin the wan port... and you are faced with EXACTLY the same situation.

1 Like

Ok thats fair, so how do I figure out correct ip settings and what is the syntax to put those in the network config file? Im open to reading good articles if you can recommend any you think would give me relevant network skills.

  • set your client to dhcp or give it a 192.168.1.x address
  • go to the in your browser
  • go to the openwrt network settings and change it to dhcp (apply unchecked)
  • find out what address it got from your main router

you can then access the internet... install your drivers and continue

1 Like

how do i set the client to dhcp? is that where editing /etc/config/network comes in?

would this be enough:

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'

wait, i dont see how that will work, i cant access, i think its cause the pi doesn't have built in wifi.

EDIT: I had the wrong version of openwrt - though my pi was a b+ but it was just a b, and thats why i couldnt ssh into it or access, now im in.

ok, i set a password and enabled ssh on the lan interface, but when i change br-lan to be a dhcp client it takes the whole 90s without applying and then it just says "Failed to confirm apply within 90s. waiting for rollback..." indefinitely.

looks like your starting to get the hang of things :robot:

it didnt work for some reason through LuCi. But i opened /etc/config/network in the terminal in vim and edited it and now its working!! i I can finally remotely log in to it :slight_smile:. im updating the package list

1 Like

WINNER! :clap: :mechanical_arm: :eyes: :genie: :woman_cartwheeling: :sloth:

now the problem is that when i enable the wireless network I set up LuCi says "wireless is not associated"

I tried forcing it with wifi up radio0 but it doesnt change pending to true

  • mark this thread as solved
  • create a new thread and
  • put the proper model in the title...
  • post the output of 'uci show wireless' in code tags ( ^</> )
1 Like

The people who wrote the quick start guides were assuming you are installing OpenWrt on a wifi router, so you always have at least a LAN and a WAN port, while a raspi obviously has only one port.

I've added information about devices with a single port in the network troubleshooting quickstart

please tell me if there are other pages you also checked where I should add the same info.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.