How to get rid of /128 addr?


The device in question has its eth0 assigned with the ipv4 address of 192.168.1.234

Interestingly, the router gave the ipv6 address of an unreachable one of xxxx::234/128, but also a reachable one at xxxx:8c7e/64.

As you can see my LAN settings, also I get my public IPv6 from PPPOE, I just can't figure out why the 234/128 addr and how to get rid of it. Sometime with the /128 address present, I can't access any ipv6 address even though the /64 address is available.

Thank you very much.

Turn off DHCPv6

The equivalent of chopping off your head when you have a headache. Seriously?

@jyc860923 why have you configured hybrid mode in IPv6 settings? Are you aware of what do they do or were you randomly changing settings?

1 Like

DHCPv6 is not required for IPv6 address assignment. RA /w SLAAC is.

@trendy AFAIK hybrid is the default, do you have a suggestion?

@LGA1150 I didn't notice any difference turning on or off dhcpv6, so I left it on. Turning it off still gets me the /128 address, and this is after I restarted the client repeatedly.

So there is probably another DHCPv6 server in LAN.

Let's see the whole picture.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ifstatus wan6; ifstatus lan
1 Like

Thank you for taking a look at my situation, the /128 device in question resides in "LAN", so ignore the lan2/3/xxx for those aren't related.

{
        "kernel": "4.14.221",
        "hostname": "OpenWrt",
        "system": "Intel(R) Core(TM) i3-9320 CPU @ 3.70GHz",
        "model": "QEMU Standard PC (Q35 + ICH9, 2009)",
        "board_name": "qemu-standard-pc-q35-ich9-2009",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.7",
                "revision": "r11306-c4a6851c72",
                "target": "x86/64",
                "description": "OpenWrt 19.07.7 r11306-c4a6851c72"
        }
}
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd8:98bc:86f8::/48'

config device 'eth3_10'
        option name 'eth3.10'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.10'
        option ifname 'eth1 eth3'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth2'
        option proto 'pppoe'
        option password '123456'
        option ipv6 'auto'
        option username '123456'
        option pppd_options 'persist maxfail 0'

config interface 'lan2'
        option proto 'static'
        option type 'bridge'
        list ipaddr '192.168.10.10/24'
        option ifname 'eth0 eth3.10 eth4'
        list ip6addr 'fdd8:98bc:86f8:1234::1/60'
        option ip6gw 'fdd8:98bc:86f8:1234::100'

config interface 'LAN3'
        option proto 'static'
        list ipaddr '192.168.20.10/24'
        option ip6assign '64'
        option ifname 'eth1.20 eth3.20'
        option type 'bridge'

config interface 'iptv'
        option proto 'pppoe'
        option password '123456'
        option username '123456'
        option delegate '0'
        option ipv6 '0'
        option defaultroute '0'
        option type 'bridge'
        option ifname 'eth1.100 eth5'
        option pppd_options 'persist maxfail 0'

config interface 'owm'
        option ifname 'eth3.2'
        option delegate '0'
        option proto 'dhcp'
        option peerdns '0'
        option defaultroute '0'

package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option force '1'
        option ndp 'hybrid'
        option ra 'hybrid'
        option dhcpv6 'hybrid'
        option ra_management '0'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'lan2'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'lan2'
        option force '1'
        list dhcp_option '3, 192.168.10.139'
        list dhcp_option '6, 8.8.8.8,8.8.4.4'
        option ra 'server'
        option ra_default '1'
        option dhcpv6 'server'
        option ra_management '1'
        list dns '2001:4860:4860::8888'

config host
        option dns '1'
        option ip '192.168.1.201'
        option name 'a'
        option mac '00:00:00:00:00:00'

config host
        option name 'b'
        option dns '1'
        option ip '192.168.10.20'
        option mac '00:00:00:00:00:00'

config host
        option mac '00:00:00:00:00:00'
        option name 'c'
        option dns '1'
        option ip '192.168.1.14'

config host
        option mac '00:00:00:00:00:00'
        option name 'd'
        option dns '1'
        option ip '192.168.10.139'

config host
        option mac '00:00:00:00:00:00'
        option name 'e'
        option dns '1'
        option ip '192.168.10.253'

config host
        option mac '00:00:00:00:00:00'
        option name 'f'
        option dns '1'
        option ip '192.168.10.202'

config host
        option mac '00:00:00:00:00:00'
        option name 'g'
        option dns '1'
        option ip '192.168.1.200'

config host
        option mac '00:00:00:00:00:00'
        option name 'h'
        option dns '1'
        option ip '192.168.20.216'

config host
        option mac '00:00:00:00:00:00'
        option name 'i'
        option dns '1'
        option ip '192.168.20.127'

config host
        option mac '00:00:00:00:00:00'
        option ip '192.168.1.171'
        option name 'j'
        option dns '1'

config host
        option mac '00:00:00:00:00:00'
        option name 'k'
        option dns '1'
        option ip '192.168.1.223'

config host
        option mac '00:00:00:00:00:00'
        option name 'l'
        option dns '1'
        option ip '192.168.1.123'

config host
        option mac '00:00:00:00:00:00'
        option name 'm'
        option dns '1'
        option ip '192.168.1.139'

config host
        option mac '00:00:00:00:00:00'
        option name 'n'
        option dns '1'
        option ip '192.168.1.253'

config host
        option mac '00:00:00:00:00:00'
        option name 'this-is-the-naughty-one'
        option dns '1'
        option ip '192.168.1.234'

config host
        option mac '00:00:00:00:00:00'
        option name 'p'
        option dns '1'
        option ip '192.168.10.136'

config host
        option mac '00:00:00:00:00:00'
        option name 'q'
        option dns '1'
        option ip '192.168.10.225'

config dhcp 'LAN3'
        option leasetime '12h'
        option interface 'LAN3'
        option ra 'hybrid'
        option limit '243'
        option ndp 'hybrid'
        option start '11'
        option force '1'
        option dhcpv6 'hybrid'
        option ra_management '1'

config host
        option name 'r'
        option dns '1'
        option mac '00:00:00:00:00:00'
        option ip '192.168.20.62'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan lan2 LAN3 owm'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option name 'allow-ipv6'
        option dest 'lan'
        option target 'ACCEPT'
        option family 'ipv6'

config rule
        option src 'lan'
        option name 'c2'
        list src_ip '192.168.1.223'
        option dest 'wan'
        option target 'DROP'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::ae16:2dff:fe94:ae58/64 scope link
       valid_lft forever preferred_lft forever
8: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xxxx:832e:cab:b401::1/64 scope global dynamic
       valid_lft 176057sec preferred_lft 89657sec
    inet6 fdd8:98bc:86f8:1::1/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::e089:67ff:fe0a:7dc9/64 scope link
       valid_lft forever preferred_lft forever
9: br-lan2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fdd8:98bc:86f8:1234::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::5c69:b5ff:fe4f:9322/64 scope link
       valid_lft forever preferred_lft forever
12: eth3.2@eth3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::ae16:2dff:fe94:ae59/64 scope link
       valid_lft forever preferred_lft forever
39: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 xxxx:832e:c72:9361:5d8f:316a:4f32:2e54/64 scope global dynamic
       valid_lft 258485sec preferred_lft 172085sec
    inet6 fe80::5d8f:316a:4f32:2e54/10 scope link
       valid_lft forever preferred_lft forever
40: br-LAN3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fdd8:98bc:86f8::1/64 scope global
       valid_lft forever preferred_lft forever
    inet6 xxxx:832e:cab:b400::1/64 scope global dynamic
       valid_lft 176057sec preferred_lft 89657sec
    inet6 fe80::e089:67ff:fe0a:7dc9/64 scope link
       valid_lft forever preferred_lft forever
default from xxxx:832e:c72:9361::/64 via fe80::4a46:fbff:fef6:8661 dev pppoe-wan  metric 512
default from xxxx:832e:cab:b400::/60 via fe80::4a46:fbff:fef6:8661 dev pppoe-wan  metric 512
unreachable xxxx:832e:c72:9361::/64 dev lo  metric 2147483647  error -113
xxxx:832e:cab:b400::/64 dev br-LAN3  metric 1024
xxxx:832e:cab:b401::/64 dev br-lan  metric 1024
unreachable xxxx:832e:cab:b400::/60 dev lo  metric 2147483647  error -113
fdd8:98bc:86f8::/64 dev br-LAN3  metric 1024
fdd8:98bc:86f8:1::/64 dev br-lan  metric 1024
fdd8:98bc:86f8:1230::/60 dev br-lan2  metric 256
unreachable fdd8:98bc:86f8::/48 dev lo  metric 2147483647  error -113
fe80::/64 dev br-lan  metric 256
fe80::/64 dev br-lan2  metric 256
fe80::/64 dev eth3.2  metric 256
fe80::/64 dev eth2  metric 256
fe80::/64 dev br-LAN3  metric 256
fe80::/10 dev pppoe-wan  metric 1
fe80::/10 dev pppoe-wan  metric 256
default via fdd8:98bc:86f8:1234::100 dev br-lan2  metric 1024
local ::1 dev lo table local  metric 0
anycast xxxx:832e:c72:9361:: dev pppoe-wan table local  metric 0
local xxxx:832e:c72:9361:5d8f:316a:4f32:2e54 dev pppoe-wan table local  metric 0
anycast xxxx:832e:cab:b400:: dev br-LAN3 table local  metric 0
local xxxx:832e:cab:b400::1 dev br-LAN3 table local  metric 0
anycast xxxx:832e:cab:b401:: dev br-lan table local  metric 0
local xxxx:832e:cab:b401::1 dev br-lan table local  metric 0
anycast fdd8:98bc:86f8:: dev br-LAN3 table local  metric 0
local fdd8:98bc:86f8::1 dev br-LAN3 table local  metric 0
anycast fdd8:98bc:86f8:1:: dev br-lan table local  metric 0
local fdd8:98bc:86f8:1::1 dev br-lan table local  metric 0
anycast fdd8:98bc:86f8:1230:: dev br-lan2 table local  metric 0
local fdd8:98bc:86f8:1234::1 dev br-lan2 table local  metric 0
anycast fe80:: dev br-lan table local  metric 0
anycast fe80:: dev br-lan2 table local  metric 0
anycast fe80:: dev eth3.2 table local  metric 0
anycast fe80:: dev eth2 table local  metric 0
anycast fe80:: dev pppoe-wan table local  metric 0
anycast fe80:: dev br-LAN3 table local  metric 0
local fe80::5c69:b5ff:fe4f:9322 dev br-lan2 table local  metric 0
local fe80::5d8f:316a:4f32:2e54 dev pppoe-wan table local  metric 0
local fe80::ae16:2dff:fe94:ae58 dev eth2 table local  metric 0
local fe80::ae16:2dff:fe94:ae59 dev eth3.2 table local  metric 0
local fe80::e089:67ff:fe0a:7dc9 dev br-lan table local  metric 0
local fe80::e089:67ff:fe0a:7dc9 dev br-LAN3 table local  metric 0
ff00::/8 dev br-lan table local  metric 256
ff00::/8 dev br-lan2 table local  metric 256
ff00::/8 dev eth3.2 table local  metric 256
ff00::/8 dev eth2 table local  metric 256
ff00::/8 dev pppoe-wan table local  metric 256
ff00::/8 dev br-LAN3 table local  metric 256
0:      from all lookup local
32766:  from all lookup main
4200000000:     from xxxx:832e:cab:b401::1/64 iif br-lan lookup unspec unreachable
4200000000:     from xxxx:832e:cab:b400::1/64 iif br-LAN3 lookup unspec unreachable
4200000001:     from all iif lo lookup unspec 12
4200000008:     from all iif br-lan lookup unspec 12
4200000009:     from all iif br-lan2 lookup unspec 12
4200000012:     from all iif eth3.2 lookup unspec 12
4200000038:     from all iif pppoe-iptv lookup unspec 12
4200000039:     from all iif pppoe-wan lookup unspec 12
4200000039:     from all iif pppoe-wan lookup unspec 12
4200000040:     from all iif br-LAN3 lookup unspec 12
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": true,
        "uptime": 83143,
        "l3_device": "pppoe-wan",
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "xxxx:832e:c72:9361:5d8f:316a:4f32:2e54",
                        "mask": 64,
                        "preferred": 172085,
                        "valid": 258485
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "xxxx:832e:cab:b400::",
                        "mask": 60,
                        "preferred": 89657,
                        "valid": 176057,
                        "class": "wan_6",
                        "assigned": {
                                "LAN3": {
                                        "address": "xxxx:832e:cab:b400::",
                                        "mask": 64
                                },
                                "lan": {
                                        "address": "xxxx:832e:cab:b401::",
                                        "mask": 64
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::4a46:fbff:fef6:8661",
                        "metric": 512,
                        "valid": 1085,
                        "source": "xxxx:832e:cab:b400::/60"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::4a46:fbff:fef6:8661",
                        "metric": 512,
                        "valid": 1085,
                        "source": "xxxx:832e:c72:9361:5d8f:316a:4f32:2e54/64"
                }
        ],
        "dns-server": [
                "2001:4860:4860::8888",
                "2001:4860:4860::8844"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
                "zone": "wan"
        }
}
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 428884,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.10",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "xxxx:832e:cab:b401::",
                        "mask": 64,
                        "preferred": 89657,
                        "valid": 176057,
                        "local-address": {
                                "address": "xxxx:832e:cab:b401::1",
                                "mask": 64
                        }
                },
                {
                        "address": "fdd8:98bc:86f8:1::",
                        "mask": 64,
                        "local-address": {
                                "address": "fdd8:98bc:86f8:1::1",
                                "mask": 64
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

I honestly don't know how telling these outputs are, as I can't even find the /128 address in it.

@LGA1150 I do have other openwrt boxes connected in the lans but they are either connected as "unmanaged" or dhcp clients, so very unlikely to have other dhcpv6 servers, I appreciate your input and I'll keep in mind to check should there be any.

uci set dhcp.lan.ra='server'
uci set dhcp.lan.dhcpv6='server'
uci set dhcp.lan.ra_management='1'
uci delete dhcp.lan.ndp
uci set firewall.wan.network='wan wan_6'
uci commit
service odhcpd restart
service firewall restart

As you can see the lan2 is using the server options, not hybrid. So I tend to believe that the default still is the server.

1 Like

I manually set "server" on LAN2 but I can try setting the same on LAN. Are you suggesting the possibility of "relay" with hybrid on is the culprit here?

It won't work as hybrid unless the wan interface is configured to relay the NDP and be the master.
So better revert them all to server, which is the correct in your scenario of delegated prefix from the ISP.

1 Like

Thanks for clearing that up. I'll give it a try.

I'm starting to think this might not be an openwrt related issue at all, since no other clients in any of the lan areas has got an /128 address, Sorry for wasting your time on this issue.

1 Like

Usually this /128 address is given by dhcp. Did you check if it is in the dhcp leases?
cat /tmp/hosts/odhcpd

1 Like

Yes, it is in there, and it shows too in luci under the DHCPv6 leases, so it is indeed a dhcpv6 issue, isn't it? Rather than RA, it's somehow getting served by dhcpv6?

And it even says Leasetime remaining Unlimited. I don't think I've ever set static DHCPv6 leases, how weird.

Then it is not an issue. You can have multiple IPv6 addresses. Since it is /128 it cannot be used for intralan communication. You can use for communication to the internet (or other interfaces).
An example from a host in my lan

dietpi@RockPi:[~]$ ip -6 ad
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2121:3434:1234:7500::5/128 scope global 
       valid_lft forever preferred_lft forever
    inet6 2121:3434:1234:7500:b84e:4cff:fed5:aaaa/64 scope global dynamic mngtmpaddr 
       valid_lft 792sec preferred_lft 702sec
    inet6 fd00:bbbb::5/128 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::b84e:4cff:fed5:aaaa/64 scope link 
       valid_lft forever preferred_lft forever
dietpi@RockPi:[~]$ ping -6 -I 2121:3434:1234:7500::5 google.com
PING google.com(prg03s06-in-x0e.1e100.net (2a00:1450:4014:80d::200e)) from 2121:3434:1234:7500::5 : 56 data bytes
64 bytes from prg03s06-in-x0e.1e100.net (2a00:1450:4014:80d::200e): icmp_seq=1 ttl=56 time=5.80 ms
64 bytes from prg03s06-in-x0e.1e100.net (2a00:1450:4014:80d::200e): icmp_seq=2 ttl=56 time=5.66 ms
64 bytes from prg03s06-in-x0e.1e100.net (2a00:1450:4014:80d::200e): icmp_seq=3 ttl=56 time=6.87 ms
64 bytes from prg03s06-in-x0e.1e100.net (2a00:1450:4014:80d::200e): icmp_seq=4 ttl=56 time=5.70 ms
^C
1 Like

I see, I don't mind having it so long as it doesn't get in the way, it all started when I was having trouble accessing ipv6 earlier, no one changed anything, god knows why it's working now. I've gotten used to the idea that IPv6 is just a moody character.

I believe it was some coincidence.
If you want to rule that out, you can disable the dhcp server on OpenWrt (it will affect all lan hosts) or limit the problematic host from soliciting dhcp6, and use only slaac.

1 Like

Yep, did thought about killall -9 odhcpd, I'll let it live till it dares next time.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.