How to get public IP on wan


I just installed openWrt on a new router D-Link DIR-878. The problem I have is with the WAN interface - it's showing wrong ip: 192.168.178... My new router is behind a provider's device which is supposed to be ruining in a bridged mode. With this IP on WAN, I can't set up the dyndns and have it accessible from outside.

Up until now I have been using openWrt on an old router: D-Link DIR-810L, which was set up by a friend (OpenWrt Chaos Calmer 15.05.1). And on that one, WAN shows 'correct' public IP. The same one as I get, for example, here:

So I know it is possible.

Could anybody please help me with this?
Thank you.

Have you tried editing the DDNS Advanced settings as follows if Chaos Calmer supports it?


thanks a lot! It slowed the dyndns problem.

Still, I was able to use this:

on my old openWRT d-link, I could restart it to get a new IP, for example, and the 'correct' IP was shown there.

Post the contents of /etc/config/network from your old router. Format it within </>

I could be wrong but don't think your modem is in bridge mode without more information.

If there no bridge mode, perhaps just create a portforward rule on the ISP router to forward all udp/tcp ports 1 to 65535 to the 192.168.178.x IP address assigned to the openwrt router, or try putting it into DMZ if option exists.


Well, it seems that the problem was that on my providers router/modem, there was only 1 eth port that was working in a bridge mode. I had no idea it was like that so naturally, when I exchanged routers I paid no intention (apart from obvious wan port).

So for now, it seems that everything works. Thanks a lot for taking the time to answer me.

Please mark as Solved.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I clicked on 'solution' a couple of time already...
I don't understand what else you want me to do?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.