How to get back to RouterOS after OpenWrt (hap ac2)

I have reverted to RouterOS today but I admit that the routine just does not work good. Eventually I succeeded with Linux Netinstall CLI.
I seemingly did the same steps over and over again and it worked only once. After that I tried to revert another router and I just gave up for now. So as @nomadeh said keep trying. You might need lots of attempts.

This information is accessible if you search for other people unable to see the router in netinstall after installing OpenWRT, and I ripped it off the Mikrotik forums, where two kind individuals by the nicknames of dchepishev and BenjiWiebe explain just what goes wrong, but as this thread comes up first in the search results for something along the lines of 'MY ROUTER DOESNT WORK WHAT DO I DO' for me, I feel the need to duplicate the information here.

If you followed some kind of guide and switched the RouterBoard to use DHCP as its boot protocol to install OpenWRT, it will stay in this mode of operation indefinitely, until you switch it back. The problem, of course, is that the only reasonable way to switch it back, is with the WebFig interface or winbox.

The solution proposed by BenjiWiebe on MikroTik forums is as follows:

  1. Download a DHCP server onto your PC
  2. Run netinstall
  3. Run the DHCP server to allow the router to obtain an IP
  4. Connect the powered off router, then boot it into netinstall mode.
  5. The router will then appear in netinstall (but netinstall will need a restart to succeed in flashing the firmware)

BenjiWiebe proposed using the following DHCP server. He succeeded in using as the IP pool, with adapter's IP being But I had no success until I narrowed the IP pool down to, which practically forced the router to take the IP of, which netinstall expects (this, as far as my understanding goes, can be tweaked by clicking the 'Net booting' in netinstall's interface).

I also used the 6.48.6 version of the netinstall utility, but I don't know if it actually mattered or not. I just thought it at the very least wouldn't hurt anything. After I relaunched netinstall after it detected the router, I was able to flash the 6.48.6 version of the firmware successfully, and everything went back to normal. Well, except that I needed to use winbox with routers MAC address to reset the configuration to default, as the system has no configuration by default, which means that it's inaccessible through standard means.

After you go through this process, remember two things:

  1. You should immediately manually reset the RouterBoard settings (WebFig: System -> Routerboard -> 'Settings' button) to defaults, which are, according to MikroTik wiki: { 'boot-device' -> 'nand-if-fail-then-ethernet', 'boot-protocol' -> 'bootp', 'force-backup-booter' -> 'no' }.
  2. You should never touch these settings to install OpenWRT in the first place, because, as far as my understanding goes, it's entirely redundant. I was able to load OpenWRT to RAM with TinyPXE and flash it without ever touching these settings on my hAP, opting instead to hold the reset button and wait through the different boot mode options until the netinstall mode comes up (no light).

After installing OpenWRT with default RouterBoard settings, not only does OpenWRT work perfectly well, both before and after a reboot, but the router is accessible in netinstall after booting in netinstall mode using the reset button.

1 Like

Not quite. One could read the … manual: This resets the soft_config settings to defaults.

RouterBOARD reset button
RouterBOOT reset button has three functions:

  • Hold this button during boot time until the LED light starts flashing, release the button to reset the RouterOS configuration (total 5 seconds)

I absolutely agree, one definitely could RT the M, and thank you for pointing out a better way of solving this problem, if it indeed works. But, you know, when the manual inches ever so closer to Leo Tolstoy's War and Peace in its sheer volume every single day, it becomes harder for one to, you know, do that. And what one instead does, is makes a reasonable assumption that if other people didn't do something while solving a problem, it's because it led to a dead end.