How to flash OPENWRT on AP300

Hi there,

openwrt-23.05.3-ath79-generic-watchguard_ap300-squashfs-factory.bin


I tried many times following the tutorial from stephenw10, whenever the progress is 5%, the upgrade progress will be lost. then it was original firmware again, how can I flash openwrt? Below is my system information.

IP Address 192.168.1.1
Firmware Version V2.0.0.1
Model AP300

If someone could help me, that would be great. Thank you.

Try clearing your browser cache or using a different browser.

What is the IP address of your computer right now? Are you connected directly to the AP300 via ethernet?

I tried IE\EDGE\CHROME, tried incognito mode, and lost the connection at 3% of the progress bar. I connected to AP directly through cable, and set static IP 192.168.1.2


Note: This (upgrading) process will take about 1 minute. Please wait...

When 3%, the connection was lost. It seems that the device restarted automatically.

make sure your subnet mask is set correctly (255.255.255.0). And be sure to turn off wifi and/or unplug any other connections. There should be exactly one connection on your computer -- ethernet to the AP and that's all.

Can you successfully ping 192.168.1.1?

192.168.1.2
255.255.255.0
192.168.1.1

Yes, when I flashed the firmware, I turned off all other networks, see screenshot

That's a good sign.

Can you ssh to the device:

ssh root@192.168.1.1

Sorry I can only post one picture, here is another screenshot

No, I tried, but couldn't connect, connection refused, I tried to open SSHD in webui, but nothing happened after saving

ssh

Instead of posting screenshots, just post the text results

Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.
grafik
Please edit your post accordingly. Thank you! :slight_smile:

Meanwhile, as far as the router is concerned...
what happens if you set your computer to DHCP instead of static IP?

When using DHCP, it doesn't seem to get IP
169.254.171.42 255.255.0.0

ok... that suggests that the device isn't fully running, although it's not entirely clear if that's true based on this:

NOTE: DHCP is not enabled by default after flashing

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=146aaeafb7e364ca667f6ddf5c1857148e8bffb2

With that in mind, I'm not sure exactly what is happening with your device.
You might try power cycling it and see if anything happens -- first with DHCP, and then with static IP if you don't get a DHCP lease.

Oh, I saw the installation introduction there, I'll try it again myself, thank you very much for your reply, have a nice day.

It looks like it is uploading the firmware correctly. The hash it shows looks good so its failing running the actual upgrade after uploading. Hmm.
I always use Firefox to run that upgrade. Though I would expect it to work in any browser.
I forget if that WG firmware has ssh access? I believe you can run the upgrade from the CLI.
You can always connect to the serial console if you have a TTL level adapter.

Oh and I'd expect DHCP to be running after the upgrade, it always has for me. It's a problem because there's only one NIC and in the WG firmware it's a dhcp client so after it boots into openwrt you need to be careful, or quick, because it will start handing out leases. Ask me how I know! :wink:

Oh thank you very much, I'll try the console and try it based on the picture you posted before, thank you! :grinning: :grinning: