How to flash EMMC on banana pi r3

Not so sure. But I believe so. Phone is OnePlus 8 Pro and laptop Lenovo T14s which was bought a few months ago.

What should I check?

It looks like Lenovo T14S has Intel AX201 WiFi 6 802.11AX adapter which supports 5G @160MHz. I haven't tried set 160MHz on BPI-R3, because even on 80Mhz I can get pretty good speed already.

this is untrue.

the boot menu tftp actions assume, also there are no prompts to choose files.
i just setup a tftp server with a static ip of and and had all relevant files in the tftp folder and it grabbed what it needed automatically.

sorry my bad, maybe I was confused which is which. I did try all the boot menu function, there were functions that asked for IP, subnet and filename... I might not recall correctly which one.

Yes I can confirm that ThinkPad T14s has Intel WiFi 6 AX201 160MHz. Then it means 160 MHz is not functional for BPI r3 on openwrt snapshot

After upgrade Intel AX201 driver, I saw a decent speed with Chanel 120 and 160MHz.

$ iperf3 -c -p 7575 -bidir
Connecting to host, port 7575
[ 5] local port 34186 connected to port 7575
[ ID] Interval Transfer Bitrate Retr Cwnd
[ 5] 0.00-1.00 sec 92.0 MBytes 772 Mbits/sec 0 2.40 MBytes
[ 5] 1.00-2.00 sec 120 MBytes 1.01 Gbits/sec 0 3.07 MBytes
[ 5] 2.00-3.00 sec 121 MBytes 1.02 Gbits/sec 0 3.07 MBytes
[ 5] 3.00-4.00 sec 121 MBytes 1.02 Gbits/sec 0 3.07 MBytes
[ 5] 4.00-5.00 sec 111 MBytes 933 Mbits/sec 0 3.07 MBytes
[ 5] 5.00-6.00 sec 116 MBytes 975 Mbits/sec 0 3.07 MBytes
[ 5] 6.00-7.00 sec 124 MBytes 1.04 Gbits/sec 0 3.07 MBytes
[ 5] 7.00-8.00 sec 124 MBytes 1.04 Gbits/sec 0 3.07 MBytes
[ 5] 8.00-9.00 sec 116 MBytes 975 Mbits/sec 0 3.07 MBytes
[ 5] 9.00-10.00 sec 120 MBytes 1.01 Gbits/sec 0 3.07 MBytes

[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 1.14 GBytes 978 Mbits/sec 0 sender
[ 5] 0.00-10.01 sec 1.14 GBytes 976 Mbits/sec receiver

iperf Done.

1 Like

hi everyone. im trying to figure out how to install openwrt to nand without serial access (install from ssh). can anyone share the dump of your nand so that i can analyze the structure of partition? many thanks
ps, there is the commands that bootloader used to install everything to nand. but the ubi part is not very human readable

edit: i succeed. i will write down my steps if someone need it

1 Like

Hi, i got mine some days ago.
Just made a way to use the snapshot version, not the 21.02, from BananaPi.

  1. Download the latest Snapshot version (i made a custom image from some openwrt online services, with Luci, and other tools).
  2. Burn the SD image - Use the SD image, Burn it to sd using your favorite software. (This will be your emmc firmware).
    3. Set jumpers to Boot SD - Put sd into BPI-R3. use the Jumpers all HIGH, for booting from sd.

4. Copy the SD content to NAND.

After booting go to SSH.

Copy to NAND:

fw_setenv bootcmd "run ubi_init ; env default bootcmd ; saveenv ; reset"

ATENTION: Change Jumper PINS only after the reboot! The copy will be made on next boot and you still need to be on NAND.

5.BOOT FROM NAND - After the reboot, turn off, and change the JUMPERS to this:

At this time you can remove the SD.

6. Copy from NAND to emmc: After booting From nand, do a SSH login, and use:

fw_setenv bootcmd "run emmc_init ; env default bootcmd ; saveenv ; saveenv ; reset"

ATENTION: Dont change the jumpers before a new boot, the content will be copied on next boot.

7. Boot from emmc. After the reboot, turn off the BPI-R3, and change the jumpers to boot from emmc:

Done, you have now a fresh SNAPSHOT install, without needing the 21.02 version, wich is opkg broken now.

No need of a console cable.

Credits to Daniel Golle



No way that I can flash to eMMC using the last SD snapshot. I noted that there is no emmc_install UBI volume so the EMMC flash commands does nothing.

And indeed ubi info l does not list any emmc_install volume :frowning:

You have to copy image from SD to Nand first, then do it under NAND (switch selection).
SD & EMMC share the same interface, you can only activate one of them but not both.

you can directly boot a initramfs image from TFTP by setup a DHCP server.

As noted on my screenshoot I did flash to NAND and can boot from NAND, but then the eMMC "burn" option number 9 does nothing since there is no emmc_install UBI volume defined. I did check the uboot environment and menu number 9 just runs emmc_init which starts checking if exists a emmc_install volume which doesn't so the option 9 on current snapshots does nothing :frowning:

Did you follow Step 6 of @piradopirata 's post here.

fw_setenv bootcmd "run emmc_init ; env default bootcmd ; saveenv ; saveenv ; reset"


That command is the same that menu option number 9, the only diference is that sets it from OpenWRT tu run after next reboot instead of directly running it from Uboot console. On Uboot bootcmd is the comand run after boot so bvasically you're saying to burn eMMC after boot by running emmc_init which does nothing on current snapshot :frowning:

Which snapshot are you using? I just did this with the snapshot from the 13th without any issue. The commands worked as documented without serial access.

I recommend you use the SD mode from beggining, and copy the content of sd to nand, not copy to nand using the serial cable.
Maybe its broken to install to EMCC via serial on snapshot.

Running commands from OpenWRT or SSH is the same, since there is no ubi_install volume the UBoot command does nothing.

Tried with many SD cards.

You maybe could try the 21.01 custom version from BananaPi site, than do a Sysupgrade to Snapshot.
Its a sugestion.
Mine is working, but i used the old snapshot as I said. But I confirm, i'm using the lastest snapshot from emcc now (Attended Sysupgrade).

The makefile of this device needs patching too. Maybe some users can confirm this.

When Building From Source, or using the imagebuilder, The "filesystem partition size" and "Ext4 Images" options are not working also.


Are you compiling your own image ? maybe I could try that.

Yes, I started with a custom build (Selinux, luci-Openssl, wpad-openssl, odhcpd full, etc) then I updated with Attended Sysupgrade to the newest snapshot.

Did you try using the Banana pi release, then do a sysupgrade for latest snapshot (From nand), then copy the updated version to emcc?

I use my bpi-r3 as an AP, all dhcp, adblock, tor, firewall, dnsec, is done by an Openwrt x86 n5105.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.