How to fix a faulty flash BT HH5a


I tried to upgrade my HH5a running 19.07 to 21.0.1. using the upgrade bin file from the home page. LUCI won't load I get a refused to connect. I tried to edit the settings of the uhttpd files and and rcpd config files as described in section 7.40 of Bills guide but these are not present on my system.

I can ssh into the router but I'm not great with UCI so have not managed to set it up on the network with internet acess. The plan was to try a LUCI reinstall. Spare router is in place. Also I can't copy files in as the upgrade has killed the winscp permissions.

Any ideas for fixing this?

Have you tried Factory resetting the hub ? (see section 8.0 of the guide)

I tried that, that is one of the things that got me back into the hub

I still don't see the files to edit. I am thinking that it did not fully flash or flashed wrong

Are you able to use vi editor (section 10) to edit and save the existing config files?

Unless someone else has any suggestions, are you able to use serial link and restore stock BT/Plusnet firmware, or was it an eBay purchase?

1 Like

Thanks Bill,

Unfortunately was an Ebay purchase as I am not confident with small wires and solder. I managed to transfer a file (discovered sftp does not work but scp does) and so potentially could get the correct file flashed via sysupgrade, I had a play but I think I will put it away for the night and try another time.

I will update tomorrow with any progress.


fwiw, see section 4.4 of the guide.

1 Like

You have ssh access, just flash a known-good release image via ssh and sysupgrade (not saving settings) from the cli.


hi Slh,

thanks that was what I was trying to do and failed. Got it now all fixed now

  1. Had to use winsp not win sftp protocol
  2. Flashing latest firmware had no effect. I flashed an old copy of 19.07. this brought Luci back. So from there I flashed the latest firmware just to see and it is now running 21.02. Now all te expected config files are also there but I did not touch them as LUCi works.

I had to set up again from scratch but was expecting that.

Hi Bill,

I found section 4,4 and it has been very useful would not have fixed this without it. fixed now.


1 Like

Glad it is fixed.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.