How to enter failsafe on Raspberry Pi 4


I use a raspberry pi 4 with OpenWrt 22.03 installed on it (openwrt-22.03.0-bcm27xx-bcm2711-rpi-4-ext4-sysupgrade.img) to play with settings before I apply them on my router.
I removed a package that obstructs me from accessing the opkg repositories again. So I want to enter the failsafe mode to fix the problem. There is no reset button present, so I need another method of getting into the failsafe mode.
When I look at the hdmi output when rebooting, at a certain point the message:
"Press the [f] key and hit [enter] to enter failsafe mode" appears. But the pi is not listening to keyboard presses from my USB keyboard at that moment. Only after the normal mode is loading it listens to keypresses.
Then I tried the serial console, but there the same logs are appearing but not that "Press the [f] key..." message. Also pressing the f key and enter does not do anything, I always end up in the normal mode.
Why is this not working on Raspberry Pi ?


afaik you need the squashfs image to use the reset, not the ext4 image.
But I dont knoe the reset key for Raspberry, you might still need to find out, how to trigger the reset.

I tried to reflash the SD card with the squashfs image (openwrt-22.03.0-bcm27xx-bcm2711-rpi-4-squashfs-sysupgrade.img), but not possible to get into failsafe mode using the USB keyboard nor the serial console.
I also tried the facory image, also not possible to enter failsafe mode.

If you reflashed it, why would you still need failsafe mode?

Correct, I do not need it anymore. I was just curious how to get into it if I would need it again in the future. I noticed anyway that my settings survive an SD card reflash.

My guess the only (easy) way you can enter recovery mode on rpi4 is by connecting a serial cable on the gpio pins. There are further options like activating gadget mode and connecting with a usb A male-male and accesing the rpi serial console this way but that might be over complex.