How to enable IP fragmentation on OpenWrt?

My PS5 has been acting weird recently, constantly timing out randomly at points and when I did a connection test it mentioned something saying that the router might support IP fragmentation and saying if it's disabled then it will have limited network functionality. My PS5 is connected through LAN. Any help on this?

IP fragmentation is not an issue for OpenWrt. This is very vague and probably misleading error code on behalf of Playstation. Do a ip -s link in OpenWrt after you connect with ssh and post the output here in preformatted text (the </> button).

1 Like

This is what I got

BusyBox v1.30.1 () multi-call binary.

Usage: ip [OPTIONS] address|route|link|neigh|rule [ARGS]

OPTIONS := -f[amily] inet|inet6|link | -o[neline]

ip addr add|del IFADDR dev IFACE | show|flush [dev IFACE] [to PREFIX]
ip route list|flush|add|del|change|append|replace|test ROUTE
ip link set IFACE [up|down] [arp on|off] [multicast on|off]
        [promisc on|off] [mtu NUM] [name NAME] [qlen NUM] [address MAC]
        [master IFACE | nomaster]
ip neigh show|flush [to PREFIX] [dev DEV] [nud STATE]
ip rule [list] | add|del SELECTOR ACTION

Try it without the -s just ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether 3e:48:69:eb:3d:48 brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 28:c6:8e:16:1d:af brd ff:ff:ff:ff:ff:ff
6: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 28:c6:8e:16:1d:af brd ff:ff:ff:ff:ff:ff
7: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 28:c6:8e:16:1d:b0 brd ff:ff:ff:ff:ff:ff
8: br-GreenZone: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 2a:c6:8e:16:1d:af brd ff:ff:ff:ff:ff:ff
9: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 28:c6:8e:16:1d:b1 brd ff:ff:ff:ff:ff:ff
10: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 28:c6:8e:16:1d:af brd ff:ff:ff:ff:ff:ff
11: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-GreenZone state UP qlen 1000
    link/ether 2a:c6:8e:16:1d:b1 brd ff:ff:ff:ff:ff:ff
12: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-GreenZone state UP qlen 1000
    link/ether 2a:c6:8e:16:1d:af brd ff:ff:ff:ff:ff:ff

Is this the only router you have at home? There isn't much you can do in terms of fragmenting as all interfaces have the same mtu size of 1500 and I don't see any pppoe interface.

Yes, this is the only router at my home. Does this just look like an error that is coming from PlayStation themselves?

This looks like PSN don't know how to suggest solutions.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.