How to enable 300mbits on a Wifi Repeater

Dear All,

I own a Netgear EX3700 with openwrt, however maximum speed I can get on 2.4 ghz is 120 mbits, and can't go any further, owing to the fact that the router supports 300 mbits, I can't get it to work pass 120.

Is there a way to enable it? On stock fw the router runs as 300mbits but on Openwrt, is limited, making obviously a backdrop, even though loving open software.


40 MHz channel width (up to 300 Mbps) for 802.11n devices ONLY

The default max channel with of 20MHz supports a max speed of 130Mbps. Increasing this to 40MHz will increase the maximum theoretical speed to 300Mbps.

The catch is that in areas with a lot of wifi traffic (and Bluetooth etc. which share the same radio frequencies), 40MHz may decrease your overall speed. Devices should detect interference when using 40MHz , and drop back to 20MHz. YMMV.

Edit the file /etc/config/wireless, and restart the wifi AP by executing the following commands…
uci set wireless.radio0.htmode=HT40+ # or: HT40- if using channel 11
uci commit wireless; wifi

Note that option 'htmode' should be set to either HT40+ (for channels 1-7) or HT40- (for channels 5-11) or simply HT40 on versions >= to 14.07. You have to use WPA2 encryption with AES.

Also, if you're configured in a true Repeater setup, you are actually using one SSID to connect upstream, and the other for clients, your theoretical maximum is 150 Mbps, so 120 is normal.

Ok thanks for the reply.

One thing I find it weird, is that on Stock Netgear Firmware, it enables Fast Lane Technology which is basically one frequency receiving another transmitting and I get awesome speeds with it, thought of doing it same with Openwrt fw, and only get 120 mbit

I'm not sure what you mean; and your description of the technology doesn't quite match the description on the OEM website. IN addition, you never mentioned that you were using both 5.4 and 2.4.

  • What speeds did you receive with the OEM software?

On stock firmware 45 mbits on openwrt maximum 12mbit when sometimes is only 3mbits , I'm using 5ghz as client and 2,4ghz as AP