How to disable wireguard at boot

Hi So running the v21 rc1 for a week, connection are good and no issues. So as the new version do have wireguard directly in the system and no package have to be install, like if you want openvpn.. you install openvpn. But having only luci-wireguard : how can i stop or disable wireguard ? As it's not present in system/startup. i want to have it fully stop at boot and not doing a connection to the remote server. In order to lunch an openvpn connection.
thanks for precision.

Remove the wg0 interface and config, if it exists. Disable any FW rules related to Wireguard, if they exist. You can also set the wg0 interface to disabled in luci (remember to untick Bring up on boot, or set option auto '0' in config). That should leave the configuration intact, but the wireguard interface will be disabled on startup, leaving nothing on the other end for peers to connect to.


Where is that option ? For sure, a checkbox like the openvpn : enable, can be nice to have. The bring up on boot, while not being possible to use the interface to pass anything, it was still doing a wg connection to the server configured. (ver 19.77)

How do I disable Wireguard on OpenWrt? - #2 by vgaetera

1 Like