How to disable WAN DHCP (Starlink bridged)?

I wonder how can I disable DHCP on Starlink bridged because I can't connect with DHCP on my local network (OpenWRT).

When I try to connect, the router gives the WAN IP that was used for the router itself.

Plus I can't connect Apple devices with static IPs (192.168.1.X) because the address IP entered is used. I suspect it's related to IPV6 DHCP enabled by default on Mac devices.

My actual configuration:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        list ipaddr '192.168.0.1/24'
        option gateway '100.64.100.1'

config device
        option name 'eth0.2'
        option macaddr 'd8:47:32:59:b2:08'

config interface 'wan'
        option device 'br-lan'
        option proto 'dhcp'
        option hostname '*'

config interface 'wan6'
        option device 'br-lan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4 5'
        option vid '1'

config device
        option type 'bridge'
        option name 'br-wan'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'

config interface 'wwan'
        option proto 'dhcp'
        option hostname '*'

config device
        option name 'eth0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'

config device
        option name 'eth0.1'
        option type '8021q'
        option ifname 'eth0'
        option vid '1'

config device
        option name 'phy0-ap0'

config device
        option name 'phy1-ap0'
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option channel 'auto'
        option band '5g'
        option htmode 'VHT40'
        option cell_density '0'
        option beacon_int '300'
        option txpower '15'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel 'auto'
        option band '2g'
        option cell_density '0'
        option beacon_int '300'
        option htmode 'HT20'
        option txpower '12'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'thewifi'
        option encryption 'psk2'
        option key 'REDACTED'
        option macaddr 'random'
        option dtim_period '1'
        option network 'wan wwan'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid 'thewifi0'
        option encryption 'none'
        option key 'REDACTED'
        option network 'wan wan6 wwan'
        option dtim_period '1'
        option macaddr 'random'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Please add output of

ubus call system board

Starlink bypass is wired-only.

1 Like

Your current config makes no sense... I would start from the default configuration, then make and test each change one at a time.

3 Likes

I connected the starlink ethernet bypass on WAN port of my router. I have internet but not DHCP.

So static IP devices works on my LAN (not Apple ones) but their can't connect using auto-DHCP.

{
        "kernel": "5.15.150",
        "hostname": "hub",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link Archer C7 v5",
        "board_name": "tplink,archer-c7-v5",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}

Thanks for not being one of those that repeat 'format your router'.

Well, it is the case of "format your router"
The router has to be first dhcp client to connect freshly started starlink. With all openwrt defaults in regard to wan and wan6.
You can save configuration backup before reset, then unzip it to recover likes of wifi passwords etc

1 Like

To be clear, the two other contributors are not just saying that as some generic thing... your configuration is legitimately entirely nonsensical. If you don't want to reset your router to defaults, you'll end up spending way more time trying to correct the issues that are present.

To be blunt, it reminds me of the line in Apollo 13 where Gene says "What do we have on the spacecraft that's good?" and nobody can answer. So, if you really think we're just telling you to reset for no reason, I'd recommend that you go through the config, line by line, and tell us why you changed each thing.

2 Likes

If the Starlink is bridged, it will only issue one "public" (actually CGNAT) IPv4 address, so you need to configure your OpenWrt router for lan->wan routing. This is the default configuration so you should start there. If you connect a router in default configuration with WAN to the Starlink and LAN to your endpoint devices, it should provide DHCP local addresses and Internet access.

1 Like

I will not format my router, I'm here to edit what's wrong with my actual configuration.

OpenWRT is a Linux system totally customizable, some of us installed packages on it and spend a lot of time figuring things out.

My configuration worked with a different connection and stopped working on Starlink.

The replies repeating the same said by others are like spam and don't give any kind of value to the forum.

That's a clear toxic behavior with not moderation on the most repealing action I see on years at different and similar communities.

I'm open to try a default or working configuration BUT NOT FORMATTING my router.

I know I can reset the router to default and I'm posting to avoid it.

Thanks :slight_smile:

This is one in the same. Resetting your router to defaults is the same as "formatting" it.

I'm honestly not sure how. The config is borked.

Then please explain every change you have made, why you have made it, and your intent for this device on your network (what you want it to do, what services it provides). The existing configuration does not make either of these things apparent.

1 Like

It's better to reply 'I don't want to help you'.

My posts stands and it's legit. Of course you can think whatever you want.

Nothing could be farther from the truth. I have helped in literally thousands of threads. And Iā€™m willing to help you, too.

Posts, sure. Config, no. Your config is very messed up. Iā€™m not saying that to insult you, but rather to impress upon you that you need to take the advice of those on the forum who are trying to help. After all, you have come here for help because this config is not working, right?

1 Like

That configuration is faulty but since it basically bridges everything together making a layer 2 "dumb AP". That would technically work if connected to a typical home gateway which does routing instead of being a bridge to the Internet.

What you have done vs. a default configuration seems to be:

  • All the Ethernet ports are in the same hardware switch VLAN. This is appropriate for a dumb AP but you need to go back to multiple VLANs to implement lan->wan routing.
  • A plain eth0 is referred to in the config even though in swconfig, the CPU side is always tagged. This is simply wrong. In default settings with two VLANs in the switch, the eth port is eth0.1 for lan and eth0.2 for wan.
  • The same ports are in two bridges. This is not workable but fortunately br-wan never gets instantiated because...
  • The wan interface has been deleted. You need one of proto dhcp in order to link to the Starlink and obtain an IP (v4) address and gateway. Also you'd want a dhcpv6 wan6 interface (which is in the default configuration) since Starlink does support IPv6.
3 Likes

You have been given a very good (although possibly not 100% complete) description of the major issues in your config by @mk24 .

Your task now is to fix all of those things, one by one, and make sure you don't make any further mistakes in syntax and/or function. Or... you can do as we have advised -- reset to defaults. You will likely only need a few very small changes from the default state, although you have not stated the purpose of this device (AP vs router), and that will affect some of the changes you may want to make.

2 Likes

Resetting the router network configurations (interface, wireless) to defaults include the config on other packages?

That's what some of us try to avoid when this advice is given.

I've used a dumb AP repeating another wireless station before. Now I see what's wrong and I'm looking the most suitable solution for my stuff.

Thanks for the replies.

Make a configuration backup, it is next to red reset button. You can use that to restore to known broken state any time.

1 Like

So to be clear, is that the purpose of this device?

You cannot set the Starlink router in bridge mode. OOB the system only provides wireless services to local wifi enabled devices. You have only app capabilities to set SSID and split the two wifi bands. Anything else is controlled exclusively by Spacex.

The Starlink bridge mode is enabled as @brada4 said by bypassing the Starlink router entirely. The only roll the Starlink router plays in bypass mode is to provide POE PD to the Starlink terminal.

Just add the Starlink or after market bypass adapter and set your Archer up to use OpenWrt default config.

The satellite terminal setup is described here:
https://www.starlink.com/support/article/a0fe8d51-32f7-d2b9-d74a-801e31ad9f6a

What additional applications are you running on the router? If you're not going to start from defaults you still need to at least temporarily disable anything that might cause problems. Get plain old lan->wan routing working properly first.

I wish a 'reset (only) config and networks' button that prevent the need of erase everything in order to reset only the config :slight_smile:

Thanks for the replies.