How to disable overlay-fs?

My Easybox 904xDSL with NAND-flash and ubifs starts normaly from mtd12 with ubifs ubi0_0 is the rootfs and ubi0_1 the overlayfs.
But where is it devined ?
I want to start my Router from USB stick and it works well via adding bootargs root=/dev/sda1 rootfs=f2fs ...
But it have an overlay too it is on ubi0_1 and i thing it is on mtd12 because it has 256MB only
I want to disable overlayfs

# block
block: Usage: block <info|mount|umount|detect>

This should show what is mounted
# block info

The well-documented extroot scheme is simpler than mounting a USB directly upon boot, which I think would require rebuilding the kernel.

In extroot it boots normally then almost immediately re-mounts the entire / filesystem as your external drive.

If you need a large space for music, video or other data the most common way is to keep the basic rootfs and mount the external drive as a directory.

1 Like

yes but i on this device the NAND-flash make somtimes trouble and i want a method for not need them, i want to use bootargs

block info
/bin/ash: block: not found

in which package is block ? i ask because it is not possibillity to use opkg

# opkg files block-mount
Package block-mount (2018-12-28-af93f4b8-3) is installed on root and has the following files:
/usr/sbin/swapon
/lib/libblkid-tiny.so
/usr/sbin/swapoff
/etc/uci-defaults/10-fstab
/etc/hotplug.d/block/10-mount
/etc/init.d/fstab
/sbin/block

https://openwrt.org/docs/techref/block_mount

root@OpenWrt:/tmp# block info
[ 2172.001121] __nand_correct_data: uncorrectable ECC error
[ 2172.004981] __nand_correct_data: uncorrectable ECC error
[ 2172.010450] print_req_error: I/O error, dev mtdblock1, sector 0
[ 2172.020239] __nand_correct_data: uncorrectable ECC error
[ 2172.024104] __nand_correct_data: uncorrectable ECC error
[ 2172.029564] print_req_error: I/O error, dev mtdblock1, sector 0
[ 2172.035341] Buffer I/O error on dev mtdblock1, logical block 0, async page read
/dev/mtdblock12: UUID="713774106" VERSION="1" TYPE="ubi"
/dev/ubiblock0_0: UUID="8b9f1cff-2584be57-87a68a97-bfe3b753" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"
/dev/ubi0_1: UUID="08852139-6f6e-4a03-9ac4-29c7f18df472" VERSION="w4r0" MOUNT="/overlay" TYPE="ubifs"
/dev/sda1: UUID="512e0d5a-ad28-4a02-8747-d0bc5e9a3217" VERSION="1.12" TYPE="f2fs"

thanks but it does not really help, i do not know how to disable /dev/ubi0_1

The answer are adding: ubi.mtd=NIX"
Reason the device try to use the MTD-partion with the label "NIX", but they do not exist.

You are right but for this reason i want to add the differen kernelparameter to uboot-config, but how ?
How can i overide the bootargs from DTS with the bootargs ?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.