How to disable https login

After a reboot, my router login page changed to https.I don't think I did something to enable https login, and even I typed http:// ahead it's still redirected to https login page. My last change to LEDE is installed adblock. The LEDE version is 17.01.2. luci-ssl is not installed. How can I disable https login?

Actually, there is no actual package "luci-ssl".

That is just a meta-package of luci plus SSL support plus certificate generation package. You can achieve the same result just by installing luci and https libraries. Like you likely have done... Then uhttpd (the http server daemon) automatically switches to using https.

You have installed SSL/https support for adblock blocklist download, so also uhttpd utilises it.

uhttpd config file has an option to automatically redirect to https if possible. That is on by default. Just set this to 0 in /etc/config/uhttpd to enable using http login again:

 option redirect_https 1
3 Likes

Thank you. I changed uhttpd redirect option and rebooted router. But it works only in IE. In chrome I still got https redirection.

Just a guess, but likely Chrome rememebrs too much and automatically lead you to https.
You might try browsing with a private session (or whatever is the Chrome equivalent)

1 Like