How to disable 5GHz wifi w/ 2.4GHz intact


Is there an easier way to disable 5Ghz radio, but to disable that interfaces via UCI and then unload ath10k modules ?

uci set wireless.radio0.disabled='1'
uci commit
rmmod ath10k_pci
rmmod ath10k_core

Saved me some Watts and problems with roaming range....

1 Like

Unload no, if it's permanent, rmmod them post boot, in rc.local, or create an image without the ath10k packages included, using the online image builder.

1 Like

If you simply have the 5 GHz unconfigured, is that not enough? Are you sure there is more power consumption?

1 Like

It is still running albeit w/o config.
rmmod (unload) did make the change in power consumption.
Checked on PoE stats on switch uplink port

I am amazed it made a difference. Perhaps you have a more sensitive tool to measure than I.

Not that much, but if you have more APs and better roaming range w/ 2.4
(FT 802.11r still does not work in 21.+ versions)

with ~12 clients

PSE Voltage : 54.5 V PSE Reserved Power : 3.1 W
PD Amperage Draw : 53 mA PD Power Draw : 2.9 W
PSE Voltage : 54.5 V PSE Reserved Power : 3.1 W
PD Amperage Draw : 54 mA PD Power Draw : 3.0 W

modprobe ath10k_pci

PSE Voltage : 54.5 V PSE Reserved Power : 4.2 W
PD Amperage Draw : 73 mA PD Power Draw : 4.0 W

uci set wireless.radio0.disabled='0'
uci commit

PSE Voltage : 54.5 V PSE Reserved Power : 4.3 W
PD Amperage Draw : 76 mA PD Power Draw : 4.2 W

Found out that this can't be done on

Mode MikroTik hAP ac2
Target Platform ipq40xx/mikrotik

Since there is no separate module for 2.4Ghz.
All are loaded with ath10k.