How to delete this IPv6 default route?

I'd like to delete the 2nd route listed here:

default from 2001:999:x:672::/64 dev 6in4-wan6  proto static  metric 1024  pref medium
default from 2001:999:y:671:: dev 6in4-wan6  proto static  metric 1024  pref medium
2001:999:x:672::/64 dev 6in4-wan6  proto kernel  metric 256  pref medium
fdc1:8e54:45::/64 dev br-lan  proto static  metric 1024  pref medium
unreachable fdc1:8e54:45::/48 dev lo  proto static  metric 2147483647  error -113 pref medium
fe80::/64 dev eth0  proto kernel  metric 256  pref medium
fe80::/64 dev 6in4-wan6  proto kernel  metric 256  pref medium
fe80::/64 dev br-lan  proto kernel  metric 256  pref medium

I've tried a bunch of different combinations of ip -6 route del and route -A inet6 del but I can't get rid of it...

It doesn't show up in route -n either

root@LEDE:~# route -A inet6 -n
Kernel IPv6 routing table
Destination                                 Next Hop                                Flags Metric Ref    Use Iface
::/0                                        ::                                      U     1024   0        0 6in4-wan6
::/0                                        ::                                      U     1024   0        0 6in4-wan6
2001:999:x:672::/64                         ::                                      Un    256    0        0 6in4-wan6
fdc1:8e54:45::/64                           ::                                      U     1024   0        0 br-lan
fdc1:8e54:45::/48                           ::                                      !n    2147483647 0        0 lo
fe80::/64                                   ::                                      U     256    0        0 eth0
fe80::/64                                   ::                                      Un    256    0        0 6in4-wan6
fe80::/64                                   ::                                      U     256    0        0 br-lan
::/0                                        ::                                      !n    -1     1        9 lo
::1/128                                     ::                                      Un    0      3       12 lo
2001:999:x:672::/128                        ::                                      Un    0      1        0 lo
2001:999:x:672::2/128                       ::                                      Un    0      1        0 lo
fdc1:8e54:45::/128                          ::                                      Un    0      1        0 lo
fdc1:8e54:45::1/128                         ::                                      Un    0      1        0 lo
fe80::/128                                  ::                                      Un    0      1        0 lo
fe80::/128                                  ::                                      Un    0      1        0 lo
fe80::/128                                  ::                                      Un    0      1        0 lo
fe80::2f97:973c/128                         ::                                      Un    0      1        0 lo
fe80::8e3b:adff:fe1d:d6e6/128               ::                                      Un    0      1        0 lo
fe80::8e3b:adff:fe1d:d6e7/128               ::                                      Un    0      1        0 lo
ff00::/8                                    ::                                      U     256    2       18 br-lan
ff00::/8                                    ::                                      U     256    0        0 eth0
ff00::/8                                    ::                                      U     256    0        0 6in4-wan6
::/0                                        ::                                      !n    -1     1        9 lo

Please paste your /etc/config/network.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc1:8e54:0045::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.1'
        option dns '8.8.8.8 4.4.4.4'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.0.2' #this router is behind the cable modem with a static ip under DMZ
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '208.67.222.222 208.67.220.220'

config interface 'wan6'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto '6in4'
        option peeraddr 'tunnelbroker Server IPv4 Address'
        option ip6addr 'tunnelbroker Client IPv6 Address'
        option ipaddr 'my home public ip' # put this instead of empty because the wan IP is not a public IP
        option ip6prefix 'tunnelbroker Routed /64:'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0'

You [wisely] redacted the IPs; but in their entirety. You could have just removed the last 'hex-tets' that Identify the assigned subnet and machine.

Obviously, I do not see the string "0671"...so I cannot assist.

There's also other things off with the config that may hinder IPv6 Internet access on LAN; but I'm trying to stick to just the topic. I think you have another thread going for the setup of Tunnelbroker, perhaps you should consider sticking to one thread.

What's the problem with this route? It's only used with packets originating from one single address, 2001:999:y:671::, anyway.

I guess the following should delete it, but it probably will show up again if it wasn't added manually.
ip -6 route del default from 2001:999:y:671:: dev 6in4-wan6

1 Like

Problem is only Tunnelbroker support told me to delete it. They are helping me troubleshoot it