How to create an IPv6 bridge interface?

The default configuration of a 4+1 device is:

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

I want to turn this device into a 5-port switch, so I have to bridge eth1 and eth0.1:

config interface 'wan'
	option	type	bridge
	option	ifname	'eth0.1 eth1'
	option	proto	dhcp

config interface 'wan6'
 	option	ifname	'@wan'
 	option	proto	dhcpv6

# lan section removed

I cannot seem to make IPv6 work on the bridge interface wan. In the wan6 section, LuCI always shows Error: Network device is not present.

I also tried to create another bridge on wan6 again by using:

config interface 'wan'
        option type bridge
        option ifname 'eth1 eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option type bridge
        option ifname 'eth1 eth0.2'
        option proto 'dhcpv6'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '3'

And it looks like the wan6 bridge is created with no child interface:

root@OpenWrt:/etc/config# brctl show
bridge name		bridge id		    STP enabled	   interfaces
br-lan			7fff.a0f3c14c45eb	no		    	eth0.1
br-wan			7fff.a0f3c14c45ed	no				eth1
													eth0.2
br-wan6			7fff.000000000000	no

How do I enable IPv6 on the WAN bridge?

1 Like

I think you should remove either LAN or WAN and create DHCPv6 interface as an alias:
https://openwrt.org/docs/guide-user/network/network_interface_alias

1 Like
config interface 'wan'
        option type bridge
        option ifname 'eth1 eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'    # 'br-wan' also works
        option proto 'dhcpv6'

Actually this does work. For some reason, the wan bridge and this wan6 alias took me 1-2 minutes to start accepting IP addresses from the upstream DHCP server. Maybe because the CPU is slow, I think.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.