How to connect wireguard peers

I have a small wireguard setup at home (Archer C7, March 2020 build from https://github.com/gwlim/openwrt-sfe-flowoffload-ath79).
Peers can connect to the router and to other LAN devices, and access internet via WG if set in allowed IPs.
No device (LAN or WG) can connect to any WG peer, and I would like to change this so all WG peers can access each other, and can be accessed from LAN.

WG config:
Addresses: 192.168.2.1/24
FW zone: lan
Peers:
phone, allowed IPs 192.168.2.2/32
pc1, allowed IPs 192.168.2.3/32
pc2, allowed IPs 192.168.2.4/32
I tried with and without "route allowed IPs"

config of the peers:
Addresses: 192.168.2.2/32 (resp. 192.168.2.3/32 / 192.168.2.4/32 for the others)
allowed IPs: 192.168.0.0/16 (also tried 0.0.0.0/0, doesn't help)
Endpoint: router:54321
I tried adding the other peers as well, but that didn't help

What is wrong with my configuration, stopping my peers from seeing each other?

censored configs:
/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda7:f196:500a::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option mtu '9000'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr 'mac'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option delegate '0'
        option reqaddress 'none'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

config interface 'wg_d'
        option proto 'wireguard'
        option private_key 'key'
        option listen_port '54321
        list addresses '192.168.2.1/24'

config wireguard_wg_d
        option description 'phone'
        option public_key 'key'
        list allowed_ips '192.168.2.2/32'

config wireguard_wg_d
        option description 'pc1'
        option public_key 'key'
        list allowed_ips '192.168.2.3/32'

config wireguard_wg_d
        option description 'pc2'
        option public_key 'key'
        list allowed_ips '192.168.2.4/32'

/etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan wg_d'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user' #this file is empty

config redirect
        option target 'DNAT'
        option name 'wg'
        option src 'wan'
        option src_dport '54321'
        option dest 'lan'
        option dest_ip '192.168.1.1'
        option dest_port '54321'
        option enabled '0'

config redirect
        option target 'DNAT'
        option name 'ssh'
        option src 'wan'
        option src_dport '55555'
        option dest 'lan'
        option dest_ip '192.168.1.142'
        option dest_port '22'

config redirect
        option target 'DNAT'
        option name 'http'
        option src 'wan'
        option src_dport '80'
        option dest 'lan'
        option dest_ip '192.168.1.142'
        option dest_port '80'

config redirect
        option target 'DNAT'
        option name 'https'
        option src 'wan'
        option src_dport '443'
        option dest 'lan'
        option dest_ip '192.168.1.142'
        option dest_port '443'

config rule
        option name 'wg'
        list proto 'udp'
        option src 'wan'
        option dest_port '54321'
        option target 'ACCEPT'

Doesn't matter since there is the whole /24 in the server address.

Try to change that into 192.168.2.2/24 , 2.3/24 etc...
Also make sure that there is no firewall on the devices themselves.