How to connect second router to extend my OpenWrt router?

At the late of 2019, I bought TP-LINK MR3420 router and install openwrt firmware. I managed to tether my smartphone to this router so i can access the internet by following tutorial here. But then i have a problem. The range of this MR3420 is not enough to reach second floor of my house, so i want to extend it using second router i have (Huawei HG8245). I plan to use the LAN port available on the MR3420 and connect it to the LAN port on second router (Huawei HG8245) so it's able to extend the range from first router. I am not installing openwrt firmware on Huawei HG8245. I followed tutorial on openwrt bridged AP over here but still i am not able to forward the internet access to my second router. Whenever i connect my device to second router, it always says no internet access. Do you have any idea what should i do? Any step i missed? Thanks.

Those directions are for the second router to be running OpenWRT, not necessarily the first one. If you don't want to run OpenWRT on the Huawei, then its OEM firmware needs to support some sort of bridging mode for this to work. Your TP-Link should be set up as a regular router.

2 Likes

Yeah, I re-read the openwrt bridged AP and realized that tutorial is not suitable for my case.
Is there any configuration needed to set up the LAN port on TL-MR3420? Because I tried to directly connect LAN port from TL-MR4320 to my laptop using cable and still it's not giving the internet access. Thanks.

There could be a lot of reasons it's not working. Both routers need to be setup using the same subnet, subnet mask, etc. so they are running on the same network. The second router should have DHCP turned off. It the second router supports some sort of Bridged mode in its settings some of that should be taken care of automatically. But you'll need to dig into the settings to see what's possible.

1 Like

Keep the MR3420 as it is, since it's working fine.
On HG8245 turn off DHCP server for LAN and configure LAN IP and MASK to the subnet you are using in MR3420 statically or enable DHCP client if available.
Connect LAN to LAN the two routers.

3 Likes

When you connect a PC direct to the LAN port of the 3420 it should obtain an IP address and have Internet access. So fix that first. Assuming you haven't strayed far from a default OpenWrt configuration, the ethernet port should be in br-lan and the switch set up to pass that VLAN through to the physical cable.

1 Like

yup, i haven't stray so far from default configuration. i dont get it when you say:

so here is the picture of my LAN interface


which setting should i change in order to pass that VLAN into cable?
Thanks

Better post the network configuration in preformatted text (the button </>)
uci export network
This looks already weird to me.

1 Like

There should only be one IP4 on br-lan, by default it is 192.168.1.1. The 192.168.42 network is for the modem, that should be a separate network called wan.

2 Likes

Sorry about that, i'm pretty new to these things.

package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8b:e2e1:5010::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ip6assign '60'
        option ifname 'eth0.1'
        list ipaddr '192.168.1.1/24'
        option gateway '192.168.42.10'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '74:da:88:be:dd:c2'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '74:da:88:be:dd:c3'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'TetheringWAN'
        option ifname 'usb0'
        option proto 'dhcp'
        option type 'bridge'

config route
        option interface 'lan'
        option metric '100'
        option target '192.168.42.1'
        option netmask '255.255.255.255'

Here is my network configuration, thanks.

So, should i just delete 192.168.42.1 then?

Yes. Remove the gateway line from lan. Delete 'tetheringWAN' entirely. Change the ifname in wan from eth0.2 to usb0. This will use the phone as the WAN. An address will be automatically obtained from the phone by DHCP. Android phones will use a 192.168.42.X address.

3 Likes

Also remove the static route at the end of the config.

2 Likes

I tried to delete tetheringWAN entirely, then my smartphone USB tethering doesn't work. I think that setting should be kept that way.

I spent the last few days to configure my second router, and actually your first solution works. Thanks.

1 Like