How to connect my openwrt router to the Internet using PPPOE?

I have an ISP provided Alphion AONT-1143, which is a modem+router. I have connected the WAN interface of my OpenWRT router to this modem. I wanted the OpenWRT router to be directly connected to the Internet without having the modem's router in between, so I changed the protocol of the wan interface to PPPOE, with the expected VLAN ID for the interface. This gives me Unknown Error (USER_REQUEST) and Connection Failed. I found that the USER_REQUEST error could come from multiple pppoe sessions, so I clicked on disconnect in the PPPOE interface in AONT router web UI, but I still get the same error.

Did you set the Alphion to bridged mode?

Unsure if its possible for your model...

1 Like

There is an option to bridge connection in alphion aont 1143, though I am not sure if it works. I have tried to set it to bridged and tried PPPOE from OpenWRT but I get timeout waiting for PADO packets and then connection failed. Would this be because of the alphion not supporting bridged connection?