How to configure wifi in STA+AP mode

emulator@OpenWrt:/# ubus call system board
{
        "kernel": "3.10.49",
        "hostname": "OpenWrt",
        "system": "Atheros AR9330 rev 1",
        "model": "Generic AR71XX\/AR724X\/AR913X based board",
        "release": {
                "distribution": "OpenWrt",
                "version": "Bleeding Edge",
                "revision": "r42513",
                "codename": "chaos_calmer",
                "target": "ar71xx\/generic",
                "description": "OpenWrt Chaos Calmer r42513"
        }
}

My network file:

emulator@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

#config globals 'globals'
#        option ula_prefix 'fd81:285a:9f9a::/48'

#config interface 'lan'
#        option type 'bridge'
#        option ifname 'eth0.1'
#        option proto 'static'
#        option ipaddr '192.168.1.1'
#        option netmask '255.255.255.0'
#        option ip6assign '60'

config interface 'wan'
#        option ifname 'eth1'
        option proto 'dhcp'

#config interface 'wan6'
#        option ifname 'eth1'
#        option proto 'dhcpv6'

#config switch
#        option name 'switch0'
#        option reset '1'
#        option enable_vlan '1'

#config switch_vlan
#        option device 'switch0'
#        option vlan '1'
#        option ports '1 2 3 4 0t'

Wirelss files:

emulator@OpenWrt:/# cat /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
       option device 'radio0'
        option network 'wan'
        option ssid 'NCRouter'
        option encryption 'psk2+aes'
        option key 'qwertyuiop'
        option mode 'sta'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option ssid 'OpenWRT'
        option encryption 'psk2+aes'
        option key '12345678'
        option mode 'ap'
emulator@OpenWrt:/#
Follow the below command 
Restart Network services using the command
/etc/init.d/network restart
wifi status
uci show wireless
iwinfo

  • Individually, STA mode is working fine but in AP mode, It's stuck at obtaining IP address (in mobile wifi).
  • And I want to setup the AP + STA mode in my OPENWRT

Can you provide the steps for (AP) and (AP+STA) mode configuration?

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

This specific issue is common in openwrt.

except your not running openwrt, but some vendor SDK.

install proper openwrt, retest, and create a new thread.

until then, ask your vendor.

No, I am using openwrt but it's the old version.

You need a supported version, in general ath9k and ath10k adapters on ath79 platform (software successor unifying all ar71xx) support WDS and multiple AP-s around single STA client. Since you complain your version is too old for that simplistic use case.