Possible AVM BUG--How to configure simple vlan

@mk24 Thanks, Mike. What I'm trying to do is use the other Ethernet ports that currently if I plug a network cable into them and the other end of that cable to a computer, I do not get connection; that is, no access to the Internet is possible. So, now, there are only two Ethernet ports that are 'active' or work. The first one, which is WAN, and the second one. Ports 3 and 4 are not working. I'm aware about matching hardware ports to vlan ports. I'm not there yet, first, I must get ports 3 and 4 'active.' This is the main challenge now. Thanks a lot.

Looks like thia is a DSL modem/router (with no ethernet WAN port), and you need to use one of the LAN ports as WAN, right?

From your config files, I found a bit weird that the LAN pot seem to correspond with ports 0, 1, 2, 4 on the switch. Are you sure about this? Which device is this, exactly?

@eduperez thanks a lot. @psherman had helped me 'convert' one of the LAN ethernet ports as WAN. This is because the router does not have a dedicated WAN port. It is as you say a " DSL modem/router".

The only configuration I have done is the help @psherman gave me earlier, as described above.

I am at a loss what to do. But I know what I want: to be able to use Ethernet ports 3 and 4 on the device so that I can plug an Ethernet cable in them and the other end of that cable I can plug into a computer and get access to the Internet. Presently, there is no Internet connection on either of those ports.

Here is the link to that help earlier from @psherman Peter. Link

Thanks a lot.

What is upstream of the router you're having trouble with?
What IP address do you see in the IPv4 upstream (just post the fist 2 octets in bold for the moment aaa.bbb.ccc.ddd)?

@ Peter, thanks a lot. The Openwrt router is now connected to the WAN port of my ISP's router. This is how it will be connected when done with configuration. This is done now by connecting an Ethernet cable to the LAN/Ethernet port that you helped me re-purpose as a WAN port on the Openwrt router. Previously, it was connected to a switch with Internet access.

Again restating the problem: ports 3 and 4 of the openwrt router do not work. That means when i connect an ethernet cable to them, I do not get an IP address. But when I do so on port 2, I do. So, it's like ports 3 and 4 are not 'active' and may need to be configured in the vlan, for which I need help. That's my diagnosis, however.

I have taken a picture and shared here, perhaps words don't well express the technical bits. These pictures are from the 'overview' page of Luci:

Thanks a lot.

You don't need to redact RFC1918 addresses (i.e. anything in the 192.168.x.x, 10.x.x.x, 172.16.x.x-172.30.x.x ranges).

I'm going to take a guess that the gateway address there (under your redaction) is 192.168.1.1.

Your network file (posted here) indicates that your OpenWrt router has a LAN defined as 192.168.1.1.

From the earlier thread, @mk24 had advised the following:

I'm guessing you missed that... If my hunch is correct, you need to change your LAN address, then renew your computer's IP address and you should be able to get online.

@psherman I have since changed that to 10.0.1.1.

ok... please post your current network file.

The Openwrt router address is presently: 10.0.1.1. Again, I'm able to go online using hardware Ethernet port 2 on the openwrt router, but not ports 3 and 4, when I connect a cable to these hardware ports.

Let's review your network file again... I want to look at exactly what is running on your device now.

@psherman Thanks, Peter. Here the result from cat /etc/config/network:

Again, please note, the IP is no longer 192.168.x.x

cat /etc/config/network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix ''xxxxxxxxxxxx'::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr ''xxxxxxxxxxxx''

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'dsl0'
	option macaddr 'xxxxxxxxxxxx'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth0.2'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '4 6t'

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

According to the file you just posted, it is still 192.168.1.1.

OK. I have done a new one. That was the old file but was pointing out that as regards the IP, it had changed. For example, as you can see WIFI is still not yet set up. That's for another day :slight_smile: Thanks for your patience, I must say!

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdad:7158:cc26::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr ''

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.0.1.1'

config device
	option name 'dsl0'
	option macaddr ''

config interface 'wan'
	option proto 'dhcp'
	option device 'eth0.2'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '4 6t'

Thank you. Next thing to look at ...

your device appears to have 2 100Mbps ports, and 2 1000Mbps ports. Let's verify that the ports are physically up.

You clearly have 2 ports working (the upstream port and the computer that you're using on that router) -- correct? Take a look at the switch page on LuCI and verify that both of those ports indicate an active link. Then take another ethernet device and connect it to each of the other two ports in turn. Does the port indicate a physical link has become active on each of those ports?

@psherman No, it's thanks to you.

To your questions; yes, the upstream port, that we converted to the WAN port, and thus upstream, and the next physical Ethernet port works.

I have connected the non-working ports and the image below reveals the results. The one that shows active connection is to a linux machine, but the machine cannot access Luci. The other, port 3 is to my osx machine. Here, it simply says 'no link' though the port is connected. The picture perhaps says more.

This picture prior to making the connections you asked for:

The Mac is indicating a physical link is up, but that it is unable to get an IP address. Your switch shows that 3 physical ports have links... are you certain that port 3 on the switch page actually equates to port 3 on the physical case?

Please unplug the Mac and watch to see if there is any change in the switch port active indicators (you should see the Mac also indicate that the cable is not connected). If there is a change, tell us which one goes down (and then back up again when you plug it back in) as well as the corresponding physical label on the case for that respective port.

No, I am not certain that port 3 on the switch page actually equates to port 3 on the physical case? I done no other switch configuration aside the one we did in a different thread.

The hardware label LAN 3 and LAN 4 when the mac is plugged, see image result. Both give same result.



on this last image, this is immediately after plugging the cable on the mac. Red turns yellow, as seen above.

Something is not right... now both 3 and 4 show down, but the Mac sill shows that it is connected. Please verify that the cable going to the Mac is actually the one you are unplugging.

It is, Peter, time and again, I checked and even changed the cable.

Your Mac is indicating that it has a physical connection. If you have really unplugged it, that should say that Ethernet is not connected.