How to configure my router?

Hey guys,
I'm new here and i want to know, how i have to configure my Router to get internet access with my clients.
I installed OpenWRT on my FritzBiy7530 and now i don't know how to continue. Is there a detailled guide or does somebody know how to do so?

The router should get an public IP from the provider via an outdoor unit with a SIM inside. It also should work as an DHCP-Server so my clients get an IP address an get access to the internet.

I have no plan how to do so...

The default configuration of OpenWrt should do the trick. You just need to login and setup your wifi (country code, ssid, encryption type, passphrase, and then enable wifi).

https://openwrt.org/docs/guide-quick-start/start

?
The FRITZ!Box 7530 is a gateway device (modem & router) and is intended to connect a telephone cable via the DSL port on the back of the FRITZ!Box 7530.

How are the outdoor unit and the Fritz!Box connected ?
I do hope you didn't use the DSL connector for this...

That's correct. But you could also re-use a LAN port as a WAN port and connect something different to it.

Fritzbox and ODU are connected via LAN on LAN Port 1 of the FritzBox

If your FritzBox doesn't have a dedicated ethernet wan port, you'll just need to split port 1 out for use as a wan.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.162",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 5 (v7l)",
        "model": "AVM FRITZ!Box 7530",
        "board_name": "avm,fritzbox-7530",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "ipq40xx/generic",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'j'
        option tone 'b'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr 

config interface 'wan'
        option device 'dsl0'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 '1'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'


I'm still using the default config, nothing's working. Only DHCP works

Remove lan1 from br-lan:

Then use it in the wan interface:

config interface 'wan'
        option device 'lan1'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 '1'

And of course, add your credentials if your ISP uses PPPoE, or set it to DHCP or static, based on whatever your ISP requires.

Typing those commands in Putty vis ssh i guess?
I'm getting a static IP from my ISP via 5G SIM in the ODU

I use the vi text editor to make the changes (within an ssh session).

Refer to the documentation from the ISP. If they give you static IP information, it will consist of an IP address, subnet mask, gateway/router, and likely DNS servers. If you are not given that information, it is probably DHCP for your connectivity (even if you have a static IP, they can deliver it to you via DHCP).

Maybe I'm too dumb to understand, but how do i remove lan1 from br-lan and config it as wan? I didn't use putty or openwrt in the past

Sorry

You open the file in vi, and delete the list ports 'lan1' line from br-lan.
Then you change the device in the wan interface.

You can also copy the file to your computer (via scp), make the edits on a text editor on your computer, and then copy it back into place.


i think i did it the right way. Ready for the next step

The screenshot doesn't tell us the full story -- let's see the latest /etc/config/network file.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'j'
        option tone 'b'
        option ds_snr_offset '0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr 

config interface 'wan'
        option proto 'dhcp'
        option device 'lan1'


That looks fine. Is it working as expected?

Should i get internet access?

In theory, yes... but you redacted the IPv4 address, so I don't know if it is working. Don't post a public IP address, but if it beings with 192.168.1.x, we need to make another change.

Is internet working?

what happens if you issue the following commands on the router?

ping 64.226.122.113
ping openwrt.org