How to configure ipsec with xl2tpd on client side

cat /etc/ipsec.conf

config setup

conn %default
ikelifetime=60m
keylife=20m
rekeymargin=3m
keyingtries=3
keyexchange=ikev1
authby=secret
ike=3des-sha1-modp1024!
esp=3des-sha1-modp1024!

conn myvpn
keyexchange=ikev1
left=%defaultroute
auto=start
authby=secret
type=tunnel
leftprotoport=17/1701
rightprotoport=17/1701
right=REMOTE_IP
rightsubnet=REMOTE_LAN/24

cat /etc/ipsec.secrets

: PSK "SHARED_SECRET"

# cat  /etc/config/network
[...]
config interface 'ipsec0'
    option auto '0'
    option ifname 'ipsec0'
    option proto 'l2tp'
    option server 'REMOTE_IP'
    option username 'USERNAME'
    option password 'PASSWORD'
    option ipv6 '0'
    option mtu '1280'
    option checkup_interval '6'
    option pppd_options 'noccp refuse-eap require-chap debug'
# cat /tmp/l2tp/options.ipsec0
usepeerdns
nodefaultroute
ipparam "ipsec0"
ifname "l2tp-ipsec0"
ip-up-script /lib/netifd/ppp-up
ipv6-up-script /lib/netifd/ppp-up
ip-down-script /lib/netifd/ppp-down
ipv6-down-script /lib/netifd/ppp-down
# Don't wait for LCP term responses; exit immediately when killed.
lcp-max-terminate 0
user "USERNAME" password "PASSWORD"
mtu 1280 mru 1280
noccp refuse-eap require-chap debug

**

> *it is my configuration but is is not connecting to server*

**