[How-To] configure and setup USB Alcatel LTE Link Key IK40 and Alcatel LTE MW40V

check you device with lsusb command (usbutils package):

:~# lsusb
Bus 001 Device 005: ID 1bbb:0195 T & A Mobile Phones

NOTE: change static IP address of your LAN to 10.0.0.1 instead of 192.168.1.1. Because on this address 192.168.1.1 you will have administration page of your LTE USB modem.

Install the following packages:

opkg update
opkg install kmod-usb-net-rndis usb-modeswitch

edit the /etc/config/network file and put the following at the end:

config interface 'lte'
	option ifname 'usb0'
	option proto 'dhcp'
	option apn 'internet'

Open file /etc/config/firewall and locate config zone , where under it should be: option name 'wan' and add lte

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'lte wan wan6'

save, reboot and it's done.

1 Like

Alcatel IK40 / IK40V
I have added some general details and some adaptions for OpenWRT 21.02/22.03/23.05.rc2 (identical config for both versions):

  1. Install packages:
opkg update
opkg install kmod-usb-net-rndis usb-modeswitch usbutils
  1. Plug LTE stick into router USB (With SIM-PIN1 deactivated, this avoids having to configure the PIN in OpenWRT config files)

  2. Check that the LTE stick can be found:

lsusb

Expected result is a device 1bbb:0195, as this is the identifier for the IK40:
Bus 001 Device 005: ID 1bbb:0195 ....some display text string....

  1. Edit file /etc/config/network

You must modify the DHCP range ipaddr of interface lan to anything other than 192.168.1.x, as the range 192.168.1.1/24 will get claimed by the Alcatel IK40 once configured as interface. E.g. modify existing ipaddr value to:

config interface 'lan'
	...
	option ipaddr '192.168.2.1'
	...

Furthermore at the end of /etc/config/network add the following block:

config interface 'lte'
	option device 'usb0'
	option proto 'dhcp'
	option apn 'internet'

  1. Edit file /etc/config/firewall and locate config zone of option name wan and insert the line list network 'lte'
config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	# insert the following line to assign the IK40 interface to the wan zone:
	list   network		'lte'
	...
  1. save files, unplug WAN Cable on router, reboot and it's done. Internet will now go via LTE stick.
    Remember that the OpenWRT router now has a new LAN IP address (see step 4)

  2. [optional] check routes on OpenWRT device, to see that Internet stuff now gets routed to usb0:

ip route

Output:
default via 192.168.1.1 dev usb0 src 192.168.1.189
192.168.1.0/24 dev usb0 scope link src 192.168.1.189
192.168.2.0/24 dev br-lan scope link src 192.168.2.1

(update: 07/2023: works unchanged for 23.05.rc2)

3 Likes

Hi there @Pico and @pilovis ,

Thanks for the above writeup. Question: I want to use the USB LTE router as a fallback option to my fiber wan connection. Do you happen to know what else needs to be done in order to assign less priority to the LTE connection, so that only when you my main wan connection goes down, connectivity automatically transitions to LTE.

Thanks!

hi

these 2 might be worth a try:

  • changing the metric on the routing route to the lte interface
  • mwan3 package (more complicated, but more options)