How to configure 2.4 and 5 GHz with 2 SSIDs

Hello,

How can I have the 2 radios operating under the same interface with 2 different SSIDs? But the clients should be in the same subnet, regardless which of the two SSIDs they connect to.

BR,
techmol

Both radios/ interfaces are configured individually, just assign them different access credentials (ESSID and PSK).

2 Likes

Ok, I have assigned different SSIDs for wlan0 and wlan1

But devices can only connect to the one I select in Interfaces. So, when under Interfaces WIFI I put wlan0 as device. Then clients can only connect to wlan0

For wlan1 no IP is assigned. Clients can't connect.

the radions themselves don't require any IP.

or are you talking about the clients ? most will only let you connect to one radio at a time, unless the client have several radios.

2 Likes

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp
1 Like
 -----------------------------------------------------
 OpenWrt 21.02.3, r16554-1d4dea6d4f
 -----------------------------------------------------
root@abz:~# ubus call system board; \
> uci export network; uci export wireless; \
> uci export dhcp
{
	"kernel": "5.4.188",
	"hostname": "abz",
	"system": "ARMv7 Processor rev 5 (v7l)",
	"model": "AVM FRITZ!Box 4040",
	"board_name": "avm,fritzbox-4040",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.3",
		"revision": "r16554-1d4dea6d4f",
		"target": "ipq40xx/generic",
		"description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8e:d583:6935::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option device 'eth0'
	option ipaddr '192.168.210.1'
	option ip6assign '64'
	option gateway '192.168.100.35'

config interface 'wan'
	option device 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	list dns '179.9.93.198'
	list dns '179.9.1.117'
	option ipaddr '192.168.100.35'
	option gateway '192.168.100.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config interface 'WIFI'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.160.1'
	option type 'bridge'
	option gateway '192.168.100.35'
	option device 'wlan0'

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option country 'DE'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2'
	option key 'xyz'
	option ssid 'ABX1'
	option network 'WIFI'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'DE'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'ABX2'
	option encryption 'psk2'
	option key 'xyz'
	option network 'WIFI wifi5'

package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	list server '176.9.93.198'
	list server '176.9.1.117'
	option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'WIFI'
	option interface 'WIFI'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config host
	option name 'x250'
	option ip '192.168.210.120'
	option mac '1234'

config host
	option name 'KM89FB5A'
	option ip '192.168.210.200'
	option mac '1235'

config host
	option name 'LS210DFD3'
	option ip '192.168.210.101'
	option mac '1236'

config host
	option name 'x230'
	option ip '192.168.210.223'
	option mac '1236'

The gateway in lan interface is wrong, remove it.

in Wifi interface you don't need these. The gateway is wrong.

In the network option use the WIFI only.

2 Likes

It's working now as expected. Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.