How to compile openwrt on a cifs mount

I'm confusing with compile openwrt.
When I put the openwrt source codes in my home directory, everything goes well.
My home directory got not enough space, so I want to use my NAS's space through smb.
I mounted with:

sudo mount.cifs //192.168.**.**/src /mnt/NAS/dst  -o username=xxx,pass=*****,dir_mode=0777,file_mode=0777,iocharset=utf8,rw,exec,noatime,users

I can git clone and git checkout with sudo. But when I run ./scripts/feeds update -a in this floder,
It returned 'Build dependency: Please install the Python3 distutils module'.
So how could I fix this issue?

You can't.
OpenWrt can only be compiled on a case sensitive/ POSIX compliant filesystem (ext4, xfs, btrfs, maybe nfs).

1 Like

I saw the case-sensetive alert.
And I turn-on the case-sensetive in my NAS's smbd.conf
No more alert.
I think maybe it is not due to the case-sensetive?

One other required feature, that is not available with cifs, is the possibility to create symlinks.

It is not meant to work over a CIFS mount... unless you want to put in the effort to make it work yourself, I doubt you will get much support.

Allright, I see.
BTW is there any alternative method to work with remote drive?

A large ImageFile containing a suitable filesystem located on the CIFS-share would work, but the performance will probably take a noticeable hit.

Another possibility might be to use RAM-disks for some folders, and do some creative bind-mounting.

A third option might be one of the POSIX-Overlay FileSystems.

1 Like

Thanks for replying
I just tried NFSv4 and it works. The firmware has been compiled without error message

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.