How to broadcast WiFi by using the ethernet port in the router?

Okay, I have this problem for months now.. This is a basic function of any wifi router.. So, on my main router (doesn't have a wifi), I connect an ethernet cable on the lan port then connect it to the wan port of my wifi router (Archer C7 v5). I have an internet on my computer. Yey! However, whatever I do, I can't make a wifi access point so my phone and laptop can connect. Tried messing with the Network > Wireless but I really can't make a working access point. So, I searched youtube for tutorials but ALL the tutorials need some kind of existing Wifi to create a working wifi access point. So, basically a repeater and not a Wifi connection that I need since I don't have an existing wifi connection. I'm sorry if I can't explain it good enough.

Basically I want this:
My ISP Router's LAN PORT > Archer C7 Wan port > Broadcast Wifi connection > A happy me

I'm using OpenWrt 18.06.1

One option


it should be working out of the box, except that you just need to enable WiFi on your Archer C7router (and set password), as it comes disabled for security reasons.

From LuCI (or whatever the IP of your Archer C7 is)

1 Like

It says 'Wireless is not associated'

No Wifi appearing on my phone. Maybe i should try that bridgedap or dumbap

Radio0 on that router is a 5 GHz band. If your phone doesn't support that, you will not see it.

Try with Radio1.

1 Like

Tried on my Oculus Quest. It supports 5Ghz. I still can't see the SSID: Wifi Ap. Maybe I'm doing something wrong?

In network > Interfaces. Should I change something here?

As far as WiFi is concerned, all you need to do is to turn the WiFi on (and of course you should set password).

Bridged AP or Dump AP are use cases depending on your needs, but also with router mode (as the default config now), you should see the WiFi.

Are you starting from default config? You didn't change anything else?

Did you try with the other radio (radio1)?

1 Like

Are you sure you DON'T have Hide SSID option checked in the setting pages of the WiFi in LuCI?

1 Like

I'm actually currently using Radio1 as a repeater for my pocket wifi since I can't use my main internet. I don't recall changing more.. Btw, how do I check the Hide SSID option?

Here's how my interfaces look.. I didn't think it changed anything except for the WWAN

It now works!! I did a factory reset, enable the it and put a password.. It is now broadcasting a wifi!! Thank you very much!! I have this problem for more than 6 months now and today I really need a fix.. All those time watching hours of complicated youtube tutorial and I only needed a simple fix lol..

Great.You may also consider changing the setup to a bridged AP or a dump AP as @mbo2o mentioned. The choice of this, that or keeping the device as router depend on your needs really.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.