How to bring back the EA6350v3 to original Linksys firmware?

I'm a complete newbie to OpenWrt and I have no experience coding or compiling firmware. The device page is not very helpful and just lists "For switching back to the original firmware, you can use the TFTP + Serial method or use the generic "MTD write" method."

I have no idea what either of those methods are or how to do them. I've done some Googling around and haven't came across anything really helpful. I am at a loss here. Is there a simple step by step guide to bring the router back to stock firmware?


Just curious: Where exactly (link) have you found that?

Hey, thanks for your reply!

I was looking for help on this page: and the directions were towards the bottom of the page.

I've only flashed the router for the first time once last night. Will it truly be as simple as power-cycling the device 3 times as it says in the directions that you've sent me? If so, then do I just flash the latest Linksys update .bin file again to permanently bring the router back to stock?

Thanks so much.

Ah, OK. Wrong wording :slight_smile: You found that on the dataentry page, not the devicepage.

I have now added "see devicepage" to the Installation methods + Recovery methods datafield.

Hey tmomas,

I've done the power-cycling methods and I was able to pull up the original Linksys GUI via but I cannot access it with the standard

I've even re-applied the original Linksys update file from their support page.

Am I doing something wrong.

Thanks for your help.

What happens exactly? What are you seeing in your browser?
Any error message?

BTW: Have you cleared your browsers cache?

I performed the power-cycle 3 times as per directions. first tried to load what appeared to be a LuCl GUI in the browser and then it would redirect me to a Linksys router page saying that"somethingLuCl" was unavailable and that I had to use instead.

The website URL actually worked and I was able to log into the standard Linksys GUI where all of my previous settings were preserved. However, each time trying would redirect me to the same goofy Linksys error page. Sorry, I didn't even think of taking a screenshot at the time.

I factory reset the router twice, each time re-applying the Linsksys FW_EA6350v3_3.1.10.191322_prod.img file. Upon third bootup, I've re-entered all of my configuration settings.

So far so good. The router boots up into the Linksys firmware each time and I can get to it's GUI via the page.

Thanks so much for your help! You've saved me a trip to BestBuy.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.