How to block ip from wifi?

Untitled Diagram

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.0.0.2'
	option netmask '255.255.255.0'
	option gateway '10.0.0.1'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '100'
	option name 'eth1.100'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'br-100'
	list ports 'eth1.100'
	option ipv6 '0'

config interface 'br100'
	option device 'br-100'
	option proto 'none'

/etc/confi/wireless

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option network 'br100'

I want to block whatever comes from wifi from accessing this range of 10.0.0.0/8
I tried with iptables but it doesn't work

iptables -t filter -A FORWARD --ipv4 --in-interface wlan0 --destination 10.0.0.0/8 -j DROP