How to always annex A?

Hi friends. today I installed lede 18.06.1 on my TP-Link W8970 v1. I configured the dsl but it's always using annex M and not using annex A ! I want to always using annex A because the annex A have more speed.
here my configuration:

config dsl 'dsl'
	option line_mode 'adsl'
	option ds_snr_offset '0'
	option annex 'a2p'
	option xfer_mode 'atm'

also I'm setting the option annex 'a' but nothing changes

the screenshot from lede


and the line status:

root@OpenWrt:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          Broadcom 147.158
ATU-C System Vendor ID:                   00,00,30,30,30,30,00,00
Chipset:                                  Lantiq-VRX200
Firmware Version:               
API Version:                    
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x4, 0x0
Annex:                                    M
Line Mode:                                G.992.5 (ADSL2+)
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 4294871913 / Far: 0
Errored seconds (ES):                     Near: 116 / Far: 22311
Severely Errored Seconds (SES):           Near: 43 / Far: 566
Loss of Signal Seconds (LOSS):            Near: 29 / Far: 45
Unavailable Seconds (UAS):                Near: 1297 / Far: 1297
Header Error Code Errors (HEC):           Near: 7508 / Far: 151461
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               16.0 ms [Interleave]   6.0 ms [Interleave]
Data Rate:                                Down: 3.131 Mb/s / Up: 508 Kb/s
Line Attenuation (LATN):                  Down: 45.3 dB / Up: 26.1 dB
Signal Attenuation (SATN):                Down: 43.0 dB / Up: 24.5 dB
Noise Margin (SNR):                       Down: 12.1 dB / Up: 31.6 dB
Aggregate Transmit Power (ACTATP):        Down: 18.6 dB / Up: 12.0 dB
Max. Attainable Data Rate (ATTNDR):       Down: 3.152 Mb/s / Up: 1.909 Mb/s
Line Uptime Seconds:                      94
Line Uptime:                              1m 34s

Hmmm, really? Annex M is roughly twice as fast, from

1 Like

yeah. in TP-Link firmware the annex A on ADSL2+ speed is higher than the annex M. any way to forcing LEDE to using only annex A ?



Sorry about the brief post

You need to edit the file /etc/config/network and add the line

option fwannex 'a'

config dsl 'dsl'


Add a new option in dsl config option fwannex 'a' as @mbo2o suggested above and then reboot the router. Btw what is your Datarate profile from your ISP? You have very high line attenuation and that's why very low speed. You can try to decrease SNR offset and it can help somewhat increase your download /upload speed if your ISP allocates more than 3 Mbut/s to you?


thanks for reply. my DSL profile is 8Mb/s. but the speed from 5:00 PM down to 4 MB/s !!! without any change to SNR the SNR is always on 10.1 to 10.5. and at the 8:00 AM the speed backed to 8MB/s :expressionless:
at 5:00 PM, I decrease the SNR by -30 db to getting higher speed to 5.1 MB/s.
I don't know why the speed at 5:00 PM decreasing ! I called with ISP but said that the noise of your line is too much

thanks. I'm do it but nothing changes. always stayed with annex M

Not really, just trading between upload speed and download speed. annex M gives slightly higher upload speed at the cost of download speed. The aggregate speed UP+DOWN doesn't change much between annex A and M

1 Like

The speed slowing down can be due to your faulty line but it can also be due to peak usage times maybe. I'd suggest you to contact your ISP and change your line to Annex A if you dont even use Annex M. It will then provide you proper 8 MB/s, as I get 9.216 MB/s DL & 960+KB/s UL rate on my line for 8 MB/s Line. I also suffer from a faulty line from ISP and so my SNR is around 6-9 db and I have permanently configured my line to use -2 db in settings so I always get full speed.

1 Like

in my line between annex A and M, there are 2 ~ 3 megabites of difference in Downstream. yes the M have more upload speed but decreasing the download speed. Now I'm backed to TP-Link firmware for measuring the speed between the LEDE and TP-Link firmware. my router is TP-Link W8970 V1 and I crossflash the router to the W9980 for newer and better DSL firmware


the difference between annex A and annex M

Annex A


Annex M


SNR looks better on Annex M

But that is nothing to wonder about; with AnnexA he syncs at 508 out of 925 possible, while with Annex M he syncs at 508 of 1821 possible, meaning he can get away with loading the same number of bits on more carrier retaining more signal-to-noise-margin... And this only applies to the upstream...

1 Like

IMO Annex A is better than M because OP is always syncing at 508 kbps upload speed so decreasing download speed for no benefit is just not worth it.

1 Like

Thanks for the explanation

Have you tried working with your ISP to have your line set for Annex A?

Back in the day, my ISP was very helpful in exploring various options and setting the mutually agreed "best" on at the head end.

1 Like

I tried changing my line to Annex M a couple of times but my router never lets me use Annex M for some reason that I don't know. So I just asked them to switch me back every time.

yes. I contacted ISP, but they told me that this was not possible to changing the line to annex A. :frowning:

1 Like