How to allow a website to pass through wan interface

Hi,

as I wrote in the title, I want to have a specific website to use wan instead of my wireguard, is it possible? I did not find in PBR where I can add a specific website?
thanks

There are some examples in the PBR docs (e.g. Netflix Domains):

1 Like

I tried that but still cant reach de website if I use wireguard.

I added that into pbr config

ie ;

config policy
        option name 'xxx Domains'
        option interface 'wan'
        option dest_addr 'xxx.net'

What does your Wireguard peer setup look like in /etc/config/network? I imagine you shouldn't route allowed IPs using option route_allowed_ips '0' and use PBR to decide what goes where.

Also, have you checked the Wireguard section in the PBR docs?

1 Like
cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option peerdns '0'
        list dns '9.9.9.9'
        list dns '1.1.1.1'

config interface 'wg0'
        option proto 'wireguard'
        option private_key 'iFxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx='
        option mtu '1390'
        option metric '10'
        list addresses 'xx.x.x.x/32'

config wireguard_wg0
        option description 'toronto'
        option public_key 'bXxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxQ='
        list allowed_ips '0.0.0.0/0'
        option route_allowed_ips '1'
        option endpoint_host '16xx.xx.44'
        option endpoint_port '51820'
        option persistent_keepalive '25'