How to add "switch0" option in luci

Hi guys,

Im using 2 devices running openwrt 1st is banana r4 with 24rc4
And the other is tplink c6 v3 23.5 the thing is i want to set VLANs on my banana r4 so how to add such option

Ty.

I believe that your Bpi R4 is using DSA, so there is no switch menu, and it cannot be aded. Instead, you use bridge-VLANs to setup VLANs. (Your C6 is using the older swconfig method.)

https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial

If you need help setting up VLANs with DSA, let us know and we can guide you through the process.

1 Like

oh , well it really uses DSA as you mentioned

fi
You have DSA
root@OpenWrt:~#

`
And yes i would be happy if you helped me to set up a VLAN i actually only need to set up 1 VLAN thats it

how to to start?

here where i can specify which port is VLAN?
strong text

You can add the VLAN IDs on the left, then select between t (tagged), u (untagged) and u* (untagged+PVID) for each port. I recommend using u* wherever you have a need for untagged to make it explicitly the PVID, too.

Note that you can only have a single VLAN as untagged on each port. You can have many tagged VLANs, of course.

There is one really important thing, though... your lan interface will need to be updated with the VLAN you choose -- often VLAN 1. This must be done before you actually apply the bridge-vlan changes so that all of the changes take effect together. So if you use VLAN 1, for your lan, the device in the interface becomes br-lan.1.

Does this make sense? If not, I can easily guide you with the text configs.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
2 Likes

What is this vlan for? If you only need to tag a VLAN on the wan port for the ISP modem you can do that by changing the wan interface Device to wan.N such as wan.835.

If you need switching of a vlan between multiple ports you have to set up using full DSA.

1 Like

i simply want to use sqm with different ports e,g port 1 and 2

i want to set one vlan is full speed and the other is limited speed

  "kernel": "6.6.67",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 0",
        "model": "Bananapi BPI-R4",
        "board_name": "bananapi,bpi-r4",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0-rc4",
                "revision": "r28211-d55754ce0d",
                "target": "mediatek/filogic",
                "description": "OpenWrt 24.10.0-rc4 r28211-d55754ce0d",
                "builddate": "1734915335"

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:96da:63ba::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'wan'
        list ports 'eth2'

config device
        option name 'wan'
        option macaddr 'redact'

config device
        option name 'eth2'
        option macaddr 'redact'

config interface 'wan'
        option device 'eth3'
        option proto 'dhcp'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcpv6'

Great. Now we just need to know which VLANs you want on each port and if any VLANs should be untagged on each port.

1 Like

i want to use port 3 as VLAN(since my r4 only has 3ports) i want to isolate it
and the remaining ports should be normal

Will you be using port 3 on its own, wil it also be used with wifi from this device?

1 Like

nope i dont think wifi is mandatory thing here.

Ok. It is as simple as removing port 3 from br-lan and then using lan3 as the device in a new network interface.

This isn’t technically VLANs when we are precise with the definition of VLANs. You are simply creating 2 interfaces with corresponds to 2 subnets. Similar, but not actually using VLANs which involve 802.1q tags.

1 Like

mmm .. how to do so.

by deleting you mean i delete it from this file?

cat /etc/config/network
config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'eth1'

Yes, you'll edit br-lan so that it looks like this:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'eth1'

Then you can create a new network interface using port lan3:

config interface 'lan2'
        option device 'lan3'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

Don't forget to also add a DHCP server and assign the network to a firewall zone.

1 Like

i believe i acheived my goal. here i deleted the lan3 from the bridge

made new device using port 3


image

im not sure of what i did. i was following some video on yt .. configuring through CLI is far beyond my level, however now i can segment my network which i control my whole homenetwork throuh port 3 and putting some restrictions

thanks for help

Aaaa one more thing.. when i sqm the port 3 it doesnt provide true value as i commanded. here for example on eth3 i get 80mbps

on port 3 it only gives an 8mbps

this is a test with enabling sqm on port 3, without sqm i get full speed on all ports

You do not need a bridge if you're using just one port and no wifi. But, if you are setting up a bridge, you actually should use a single bridge and bridge-vlans to separate the ports.