How network.device status works?

Hi All,

At my developing device, we have lo and wlan0 interface.
And I already set up correct UCI setting for wlan0 interface.

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'wlan'
        option ifname 'wlan0'
        option proto 'dhcp'

root@OpenWrt:/etc/config# cat wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ocp/18700000.sdhc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option hwmode '11g'
        option channel '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wlan'
        option ifname 'wlan0'
        option mode 'sta'
        option ssid 'AAAAA'
        option encryption 'psk'
        option key 'dafedadfe'

When I do wifi up, nothing happened. Even I check the log from logread, still nothing.

I try to follow netifd to debug issue.
Looks like my device did not show up from ubus call network.device status.

root@OpenWrt:/etc/config# ubus call network.device status
{
        "lo": {
                "external": false,
                "present": true,
                "type": "Network device",
                "up": true,
                "carrier": true,
                "mtu": 65536,
                "mtu6": -1,
                "macaddr": "00:00:00:00:00:00",
                "txqueuelen": 1,
                "promisc": false,
                "rpfilter": 0,
                "acceptlocal": false,
                "igmpversion": 0,
                "neigh4reachabletime": 30000,
                "neigh6reachabletime": 0,
                "neigh4gcstaletime": 60,
                "neigh6gcstaletime": 0,
                "neigh4locktime": 100,
                "multicast": false,
                "sendredirects": true,
                "statistics": {
                        "collisions": 0,
                        "rx_frame_errors": 0,
                        "tx_compressed": 0,
                        "multicast": 0,
                        "rx_length_errors": 0,
                        "tx_dropped": 0,
                        "rx_bytes": 43006,
                        "rx_missed_errors": 0,
                        "tx_errors": 0,
                        "rx_compressed": 0,
                        "rx_over_errors": 0,
                        "tx_fifo_errors": 0,
                        "rx_crc_errors": 0,
                        "rx_packets": 622,
                        "tx_heartbeat_errors": 0,
                        "rx_dropped": 0,
                        "tx_aborted_errors": 0,
                        "tx_packets": 622,
                        "rx_errors": 0,
                        "tx_bytes": 43006,
                        "tx_window_errors": 0,
                        "rx_fifo_errors": 0,
                        "tx_carrier_errors": 0
                }
        }
}

Who can help me to understand how this works? Thanks a lot.

There is a patch, 600-ubus_support.patch at hostapd.
This change provide wifi device info for other daemons.
Thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.