(How) is it possible to give the devices for 2.4 and 5ghz wifi the same configuration on network layer?

I would like to give them (named "wlan0" and "wlan1" on my device) the same ip, netmask, and routing info.

I want to do this for multiple reasons, but the most important:
I'm using static leases in dnsmasq and can only bind 1 ip to each mac which means that if i connect it to the other interface it will receive a ip in a range that is not routed.

PS: If possible I would like to use a different ESSID for the interfaces, but I don't mind if I have to use the same.

Nor use wwan1 or wwan2 but only lan
option network 'lan'
option encryption 'psk2'


Just create/place both SSIDs into a LAN bridge. If you only want one SSID per chip, then yes, you can just specify wlan0 and wlan1 (it's not required, though).

Wait...are these client connections, or for an AP?

1 Like

This is the default configuration anyway. There is a bridge named br-lan which is the device for the network 'lan'. Anything in the bridge will use the bridged network's layer 3 settings. A bridge works at layer 2, it is like plugging virtual cables into a virtual Ethernet switch. When you want wifi users on either band to use the same network, use a bridge. Do not create a separate network for each AP device.

On each wifi AP's configuration page, at the bottom there is a box to choose the network, choose 'lan' there. Or if you are using CLI, it is option network 'lan' in /etc/config/wireless.

The SSIDs are allowed to be the same or different, there are reasons for and against setting up either way.


I now tried these things:

  • Made a bridge device of wlan0 and wlan1 each with there own essid, made a interface based on this bridge with a dhcpv4 server → My laptop sees the 2 the essid's but doesn't receive a IP

  • Did the same but without dhcpserver, instead i gave both my laptop and the interface ip's on the same subnet → Laptop also sees the essid's but pings (or other traffic) still doesn't work.

  • Tried the 2 things above but with the same essid for both wlan0 and wlan1 → same results (but obviously my laptop only sees 1 essid this time)

Why don't you try to go back to the default configuration, where this setup works out of the box?

It never worked out of the box.
Right after flashing the factory image it gave me a bridge device of the port's for RJ-45's.
Wireless was never in bridge.

Edit: I forgot to mention the device. It's a LinkSys EA6350 v4 . Also note that the lastest stable (21.02.1) does not support this yet so I used the snapshot image.