How install OpenWrt on TP-Link W8970 ver 1.2

i look this explained
and last thing Stop him !
the file
i download one file .bin not .image !
and why is two part
sysupgrade.image & sysupgrade-1.image ???????
and After install OpenWrt can be return to the original firmware of TP-Link ( without opening the case ) ???????

You were looking at a very old forum post. Did you look at the instructions at ... do they make more sense to you?

if install openwrt can be return to official tp-link firmware without open the case ?

I don't think so.

need open case to return the tp-link firmware ?
the tp-link firmware is the best or openwrt ?
and when install openwrt the internet is work or need install some file ?

Probably yes. I'm not aware of a way to do it without serial connection.

We can't decide that for you.

The internal modem should work out of the box for ADSL and VDSL. VDSL using vectoring or internet via WAN port (DHCP or an external modem) requires a bit of additional configuration because the W8970 does not have a dedicated WAN port.

1 Like

i follow this steps the router install openwrt and then reboot from in origonal UI TP-Link
the router is reboot and not work !
not get ip
:frowning:how to fixed it ?

the connection by lan is lost
how to fixed it ?
bad firmware openwrt damage the router

These are the instructions for the TP-Link W9980. You might have damaged your router by following the wrong instructions.

Also, "does not work" is not very helpful. What does it do when it reboots, in particular, what do the LEDs show? What is blinking, what is not?

We are not at this point yet, but you may have to open the case and connect via serial to repair (or go back to the manufacturer's firmware.)

Not helpful, again. I realize you are frustrated now, but it is not OpenWrt's fault.

only led power + lan led on !

Does it blink, in any way, when booting?

it blink !
but i think the router is damage
i replace it and not used openwrt again

i install openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade.image
damage the router

Please say exactly how it is blinking. The LEDs are the router's way of telling the outside what is going on.

Otherwise noone will be able to help you, "damage the router" is not a description anyone can take to tell what is wrong, and how to correct it.

1 Like

lan led is flash and not get gate way ip !

serial port cable ( open case ) used LAN or USB port ?????

lan is fast flash and get this ip only
the same problem

You should be using this file:
I don't know where you found one named ".image".

LED's blinking is a good sign, it means the bootloader is likely still intact.

It may have TFTP recovery like many TP-Link models, but really serial looks like the way to go to debrick this model.

i open the router and makes ( pins ) then install firmware all is ok now but wifi toggle button into the router is Damaged ( always on ) can`t off but in can off/on wifi by openwrt
search for this toggle button ( in Egypt/Cairo ) not found !
the wifi toggle button Break the stirring key
try disolder by 60 watt welding solder ( Not melted )
try add flux ( Not melted )
try add new solder into old solder ( Not melted )
Note that in this router ( all solder is very hard to melted it )
TP-Link Factory used Specific solder ? hard to melted ?
So that the device can not be maintained when it is damaged and is changed ?IMG_20181215_212248
i used this japan goot 60 watt ( original ) !

Please stop using the word "damaged" if something is just not working, especially if, like in this case, it is not expected to work.

OpenWrt does not react to this switch, or any switch, by default. You can insert a custom script into a special directory (/etc/hotplug.d/button) to turn off and on wifi, but that is an advanced topic and not for this topic.


They use lead-free solder which is generally a little bit harder to work with. I have done this before and, yes, two of the three necessary connections (RX and TX) are easy to solder a pin into the through-hole, for GND it is not. It might have to do with the ground plane sucking up heat. I could recommend to use another empty GND through-hole nearby, but you are already done anyway.

1 Like