How import openvpn client file to OpenWrt?

I haven't tested, but it seems to me you've given away the full login details to your VPN account. Why?

1 Like

for test on openwrt for help me

Anyway luci-app-openvpn is too clumsy.
There's no ovpn-import feature and you can't configure auth_user_pass-option.

1 Like

I've added support for it with this PR ( ... would be nice to get some feedback. Thanks!


it's good :ok_hand:

How do I get my filthy hands on it?


Take a snapshot "release" or wait for next OpenWrt release 19.x

Thanks to dibdot, I was able to whip up a little tool to import multiple .OVPN files at once.

Works with 18.06 as well.

Take a look:

OpenVPN configuration file CONVERTER for OpenWRT

1 Like

Hi I really like luci-app-openvpn, do you want to share the source code for this? I want to implement luci-app-openvpn on openwrt 18.06.4

Well, OpenWrt is an opensource project - therefore you'll find all sources in the LuCI github repo ( I doubt that this new feature will be backported/accepted in the stable branch ... IMHO "stable" means security & bug fixes only.

even though I'm waiting for luci-app-openvpn to be in a stable version

hy it turns out that it is also accepted in the stable version can you make a tutorial on how to install, luci-app-openvpn settings can be used

Hi all I have tried to use luci-app-openvpn on GL-mt300n v2 on OpenWrt 19.07.0-rc2 r10775-db8345d8e4 and trying to import ovpn file, but it does not do nothing... i press upload it blinks and nothing.

I seen that people get a editor window... Can it not be like that... just template that gives that window. so we can just copy -paste. What format that file need to be?

Does this help to convert an AS server config?

Anything in the logs (logread) during your upload attempts? What's the file size of your ovpn file?

is a standard Ovpn from cyber ghost is 398 bytes. I checked logs (openWRT logs) but did't found no entries. Can You direct me to log file. Where to find it ?
Also i tried to add it via gui but can't find mssfix

this is in ovpn

remote 443
dev tun 
proto udp
resolv-retry infinite 
redirect-gateway def1
cipher AES-256-CBC
auth SHA256
ping 5
ping-exit 60
explicit-exit-notify 2
script-security 2
remote-cert-tls server
route-delay 5
tun-mtu 1500 
fragment 1300
mssfix 1200
verb 4
ca ca.crt
cert client.crt
key client.key

I also tried empty (with just one line of text) ovpn file and it was same thing

What is your question? Put the file in /etc/openvpn/file.conf

/etc/init.d/openvpn restart
logread -e openvpn

@ulmwind - i know you can put it there, but topic is about importing it to LuCI via luci-app-openvpn app. Im trying to debug why importing of that ovpn file does not work in luci- app-open-vpn to do that i need to get acces to lucie-app-openvpn log, to check why it is not able to read it.

is all about luci :).

At end i want to have 3 wifi, 1st for normal internet, 2nd for VPN and 3rd for my IOT
And I want to do that via gui, so other green like me can folow it.

Sorry, I'm unable to reproduce your problems. I took the same router (GL-MT300N-V2), the same software (19.07rc2) and test the gui with different themes ... no upload problems at all, e.g.:

  1. step: set an instance name and select a test file (not empty!)

  2. hit upload and I'll get this ...

  3. hit edit and I'll get this ...

I have no idea what's wrong on your side, maybe a rough browser extension which blocks javascript or something like that!?

Thank You ... Found reason why... Im just Green. :slight_smile:

Now what was my problem. I was thinking that when i install Luci-App-OpenVpn is included in package... than i tried to check with putty /etc/openvpn/ folder but it was not there... i tried to start openvpn but was not there.
So solution was to instal Openvpn-openssl package. than it worked perfectly. Thanks for Your help

Now i need to test it...
i will test and post if it works