How I set the Vlan for this? AP Raspberry PI4b Vlan, problem network not working

  • Raspberry Pi4b – OpenWrt 21.02-SNAPSHOT
  • Tp-link sg105E managed switch
  • Ap on vlan ID 2

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1e:819d:204c::/48'

config interface 'lan'
        option device 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.171'
        option dns '192.168.1.1'
        option gateway '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ipaddr '192.168.3.1'
        list dns '192.168.1.1'
        option device 'eth0.3'

/etc/config/network

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key '****'
        option network 'wan'

This is what I want to achieve


My sg150E switch settings:

Port 1 isp bridged modem
Port 2 ethernet port Raspberry Pi 4b
Port 3, 4, 5 my LAN network

With current configuration, the AP does not show and I cant ssh 192.168.1.171 from 192.168.1.230

This is my switch Vlan configurations:

image

This is all very confusing...

  • Where is the modem? And the AP?
  • How is that router configured?
  • Why do you need the VLANs?
1 Like

i dont have a router that supports vlans, but thanks to replying