How I fixed my luci.ucodebridge error

Could be just some priority system like dpkg/apt has on debian where some packages are flagged as system ones and cannot be removed, but it would probably make the opkg too fat for some routers with small flash chips

Just had the same issue and it fixed for me.

it is a remedy. Thanks!

Thank you! I hadn't rebooted OpenWRT 23.05.0 (Belkin RT3200) for 250 days. When I did, I could not access LuCI, but the install command fixed it immediately.

this worked

It was one of:

  • luci-app-uhttpd - this is the one that I sudo opkg install-ed
  • lua - dependency
  • luci-lib-nixio - dependency
  • luci-lib-ip - dependency
  • luci-lib-jsonc - dependency
  • liblucihttp-lua - dependency
  • luci-lib-base - dependency
  • luci-lua-runtime - dependency
  • luci-compat - dependency

that did it for me. I'm not sure which of the above packages was the one that was missing/broken. Either way, thanks to the OP for posting that.

EDIT: forgot to mention, I'm running OpenWRT 23.05.3, "out of the box" version, not any custom compiled version, or RC version.