How do I set correct time?


How do I set the correct time in OpenWrt? My local time is 16:07pm but OpenWrt is displaying 05:37:00.
The NTP don't seem to do anything either?



Does dns resolution work for the router?
It's required for internet time sync.

1 Like

Did you set correct timezone first?

1 Like

If not timezone setting, provide more information.

What do you mean? I set the dns to the ip address of the main router and can access the internet is that the same or different?

How do I do that?


Never mind! I found this article that explains how to set the timezone.

The system setting has it, by default OpenWrt doesn't have too many menu items which you can just spend a few mins to look around.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.