How do I limit the channel width of the wireless STA mode?

Since the 160 MHz signal is poor and the network fluctuates frequently, I'd like to set the channel width for STA to 80 MHz on the secondary OpenWrt router, but it seems that OpenWrt ignores the device configuration in STA mode.

/etc/config/wireless:

...
config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/18000000.wifi+1'
        option channel 'auto'
        option band '5g'
        option htmode 'HE80'
        option country 'CN'
        option disabled '0'
        option cell_density '0'
        option mu_beamformer '1'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid '<REDACTED>'
        option encryption 'sae'
        option key '<REDACTED>'
        option time_advertisement '2'
        option time_zone 'CST-8'
        option wnm_sleep_mode '1'
        option wnm_sleep_mode_no_keys '1'
        option bss_transition '1'
        option proxy_arp '1'

However, setting it to HE80 has no effect and the router still connects to the AP via 160 HMz.

you will have to change the configuration of the router that offers 160MHz wifi, the client will automatically adapt to that offered by the main router

I don't want to sacrifice performance on the server side, I just want to provide the ability to specify the channel width on the client side to accomplish the adjustment.

if on the main router you can create multiple sids you can create one with the channel set to 80MHz and connect the two with this specific sid

This seems like a compromise that could be made, but I'm not quite sure if multiple SSIDs would interfere with the signal?

WiFi connections are subject to multiple factors that can change bandwidth.

one way is to create multiple sids by also setting the ex channel: 36, 52, etc

if you don't want any possible interference the solution is to connect them together via ethernet

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.