How do I disable ISP provided IPv6 DNS servers?

It worked fine without any problem on 19.10 and I installed OpenWrt SNAPSHOT r22658-2c530fcb97 / LuCI Master git-23.104.28202-588c6a1 on Linksys WRT1900AC v1 but now I see 4 DNS servers for IPv6 upstream.

DNS 1: 2001:4860:4860::8888
DNS 2: 2001:4860:4860::8844
DNS 3: 2001:1998:f00:2::1
DNS 4: 2001:1998:f00:1::1

The problem is that Spectrum DNS does not work and they time out. There is no uncheck button "Use DNS servers advertised by peer" for IPv6.

In the wan6 interface, set option peerdns '0' or uncheck the Use DNS Advertised by Peer on the Advanced page.

1 Like

There is no "Use DNS Advertised by Peer" in WAN6 interface. this is what I was checking in the first place. It is there in 19.10

On 23.02.3 it is still there. Go to Network - Interfaces, click Edit on the right side opposite wan6, click the Advanced tab, it is the fourth one down.

1 Like

I am using snapshot right now and used option peerdns '0' and I will upgrade to 23.xx when it is released. Hopefully this option will be there in a stable 23 version.

If someone else is using snapshot can verify that this option is there in WAN6 or not, if not a bug report should be filed.

Missing peerdns option for dhcpv6 has been recently fixed in LuCI.

4 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.