How do I disable 40MHZ in client mode

the other router cant control it it not mind so when i connect with this openwrt router to it it stays on 40mhz how do i disable make it only 20mhz i have a wifi adapter and i can connect to the other wifi with 20mhz and 40mhz if i want to
my config:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option band '2g'
        option country 'US'
        option cell_density '0'
        option channel 'auto'
        option htmode 'HT20'
        option txpower '30'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'TP_LINK'
        option encryption 'psk2+ccmp'
        option key ''
        option short_preamble '0'
        option hidden '1'
config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid '.._2.4G'
        option key ''
        option encryption 'psk2+ccmp'

see image

Welcome to the community!

If this is truly a serious concern for you - you may wish to use an upstream device that allows for the proper setting of channel bandwidth.

Unfortunately, the proper method is to set this on the AP.