How do I connect to an L2TP Radius VPN server?

So I've been messing with this for a few days. We have an L2TP Radius VPN server at work, and we want a router that can connect to it from outside our network. All traffic on that router should then go through that VPN. The guy who set it up is very budy, so I basically got some login data and have to figure the rest out myself. I have a server IP address, username, passwork, and pre-shared secret (machine authentication) key. So far, all I've been able to find usng default router firmwares such as dd-wrt or Tomato is either a VPN setup that requires an address, username, and password, but no pre-shared secret key, or a whole complicated list of settings that I can make heads nor tails of.

I'm currently messing with OpenWRT. I tried a cariety of versions in a VM and I also have an Archer C7 here with OpenWRT 22.03.2. I've tried to use luci-app-softether, but it just gives me a "Loading account information…" that never stops. I don't see any instructions on using SoftetherVPN without a GUI.

I have also tried to follow some instructions here: OpenWrt L2TP PSK VPN to Ubiquiti USG. At best, I get the following:

root@OpenWrt:~# ipsec up SaxVPN
initiating Main Mode IKE_SA SaxVPN[2] to
generating ID_PROT request 0 [ SA V V V V V ]
sending packet: from[500] to[500] (216 bytes)
received packet: from[500] to[500] (56 bytes)
parsed INFORMATIONAL_V1 request 3350795547 [ N(NO_PROP) ]
received NO_PROPOSAL_CHOSEN error notify
establishing connection 'SaxVPN' failed

I've tried googling this but I haven't gotten anything useful. I've tried some encryption settings in /etc/xl2tpd/xl2tpd.conf, but that did not help.

I've also tried installing random VPN packages, but none had any option that was useful.

It seems easy enough to connect to within something like Ubuntu. Just a GUI where you enter these 4 details, and then you connect. I was linked this: But I can't figure it out in openWRT.

What I can see on what you posted, is either the encryption mode selected on the config isn't compatible with the server since it says "received NO_PROPOSAL_CHOSEN error notify" or you're connecting through a NATed device since the reported IP on this line "sending packet: from[500] to[500] (216 bytes)" is and I don't think that's you're WAN real IP so the handshake fails (the connection is reporting a different IP than the one where the connection is coming from).
If you're case is the second, you will need to tell StrongSwan to change the reporting IP to then real WAN IP, this step I haven't done it on OpenWrt but I have done it on UniFi firmware using this article EdgeRouter IPsec Site-to-Site VPN behind NAT, this would be the wider concept you will need to adapt it.